Wicket
  1. Wicket
  2. WICKET-5224

ModalWindow is not visible in Safari when opened from a link at the bottom of a large page

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.8.0, 6.15.0
    • Fix Version/s: 6.13.0, 7.0.0-M1
    • Component/s: wicket-extensions
    • Labels:
      None
    • Environment:
      Safari 5.1.7 (7534.57.2) Windows, Safari (iOS 6.1.3)

      Description

      I am not able to see a ModalWindow in Safari and I expect to see it centered on my view port.

      Steps:
      1. Start with a large web page with a link to open the ModalWindow at the bottom of the page. You need a large page where you have to scroll down to find the link.
      2. Click the link
      3. Observe that the mask for the ModalWindow displays, but the ModalWindow does not. Scrolling back up, re-sizing, and maximizing will still not display the ModalWindow.

        Issue Links

          Activity

          Jered Myers added a comment - - edited

          When I remove the patch in WICKET-4948 on line 486 in modal.js, the problem seems to be resolved. I do not have a way to test on the Mac version of Safari. I am using Safari 5.1.7 on Windows.

          Jered Myers added a comment -

          I replicated this problem with an iPad (iOS 6.1.3) with Safari. There is a difference from my Windows Safari tests, in that I am able to see the ModalWindow when I scroll to the top of the page and then rapidly scroll back down to the bottom of the page. As soon as the window stops scrolling, the modal seems to move down out of site again...so the modal seems to move with the scroll bar.

          Jered Myers added a comment -

          Has anybody been able to look into this yet? It is holding back a release for me as my application depends on the ModalWindow being available for Safari users. I can do a custom Wicket build and patch by removing the fix for WICKET-4948, but I would rather not do that if this is going to be addressed soon.

          Martin Grigorov added a comment -
          Igor Vaynberg added a comment -

          confirmed, safari mustve changed its behavior between than and now

          Jered Myers added a comment -

          The quickstart passes now. Thanks!

          Igor Vaynberg added a comment -

          looks like this issue is back :/

          Igor Vaynberg added a comment -

          reverted the revert, seems to have fixed it.

          Luke Niesink added a comment -

          The supplied quickstart is broken when using Wicket 6.13.0. I have tested this in Safari on iOS 6 and 7 and Mac OS X. Reverting the changes made by Igor Vaynberg (https://github.com/apache/wicket/commit/61ebe2dbd55ff2ff5ac6f73909708021bb1acf4d) fixes the problem.

          Jered Myers added a comment -

          Igor Vaynberg,
          I can confirm that this bug is replicating again in 6.13.0. I also tested in Wicket 6.15.0 and the bug replicates. Is it possible to get a fix for this in 6.16.0?

          Martin Grigorov added a comment -

          Please follow WICKET-5616.
          Here it is hard to follow where this problem started, in which version it has been fixed, in which version it appeared again, ...

          Stijn Geukens added a comment -

          I have the same issue using Safari 8 on a mac on Wicket 6.14.
          Could this issue be reopened?

          Jered Myers added a comment -

          Stijn Geukens, this case was fixed and was broken again, so WICKET-5616 is the latest. The patch should be in Wicket 6.17.


            People

            • Assignee:
              Igor Vaynberg
              Reporter:
              Jered Myers
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1h
                1h
                Remaining:
                Remaining Estimate - 1h
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development