Wicket
  1. Wicket
  2. WICKET-5150

Log additional info when FormComponent fails in updateCollectionModel

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 6.7.0
    • Fix Version/s: 6.8.0, 1.5.11
    • Component/s: wicket
    • Labels:
      None
    • Environment:
      Any

      Description

      When a form component using Collections (e.g. CheckGroup) fails to set the collection in the Model's contained object due to an exception, it produces some log output that looks thus:

      INFO - FormComponent - no setter for the property attached to [CheckGroup [Component id = group]]

      This may be misleading, as any exception will produce this output, including for example a NullPointerException that occurs inside the setter itself. In other words, setter for the property may well exist but an exception sometime during the setter invocation still results in the "no setter" log feedback.

      Suggested improvement is to include some details about the caught exception in this log message that may more directly point to the cause of the failure.

      1. jira1.zip
        25 kB
        Steve Akers

        Activity

        Martin Grigorov added a comment -

        Can you provide a quickstart application/test case that reproduces the log message ?
        This will save us some time trying to reproduce it and fix it.
        Thanks!

        Steve Akers added a comment -

        This might suffice as a working example, derived from a quickstart - to see the issue, you could e.g. run in eclipse/jetty, submit the form, and observe the INFO log output. See Goat.java for some comments where the error is forced.

        Martin Grigorov added a comment -

        Improved.
        Thanks for the quickstart!


          People

          • Assignee:
            Martin Grigorov
            Reporter:
            Steve Akers
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development