Wicket
  1. Wicket
  2. WICKET-4951

Wicket-cdi and OpenWebBeans 1.1.x incompatibility

    Details

    • Type: Wish Wish
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 6.3.0, 6.4.0
    • Fix Version/s: 6.13.0, 7.0.0-M1
    • Component/s: wicket-cdi
    • Labels:
      None
    • Environment:
      OpenWebBeans 1.1.x (TomEE 1.5.1)

      Description

      It is not particularly Wicket-CDI fault to not support the latest OpenWebBeans, but rather seam-conversation-owb-3.0.0.Final, thus this issue is reported as a "wish". Seam-conversation-owb-3.0.0 depends on ancient OpenWebBeans version, although I've seen some activity in its git repositories (https://github.com/seam/conversation/commit/a5f2e3f42829f8405e6bee6caab43fd034e5be81) and 3.2.0 Snapshots deployed to jboss maven repo (https://repository.jboss.org/nexus/content/groups/public/org/jboss/seam/conversation/seam-conversation-owb/3.2.0-SNAPSHOT/) seem to depend on OWB 1.1.3. It seems that ConversationManager.getInstance() is no longer there which results in the following stacktrace when run on tomee 1.5.1 or tomcat + OWB 1.1.7:

      SEVERE: Servlet.service() for servlet [default] in context with path [/wcjs-web] threw exception [Filter execution threw an exception] with root cause
      java.lang.NoSuchMethodError: org.apache.webbeans.conversation.ConversationManager.getInstance()Lorg/apache/webbeans/conversation/ConversationManager;
      at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansSeamConversationManager.doActivate(OpenWebBeansSeamConversationManager.java:41)
      at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansHttpSeamConversationContext.doActivate(OpenWebBeansHttpSeamConversationContext.java:44)
      at org.jboss.seam.conversation.api.AbstractSeamConversationContext.activate(AbstractSeamConversationContext.java:54)
      at org.apache.wicket.cdi.CdiContainer.activateConversationalContext(CdiContainer.java:94)
      at org.apache.wicket.cdi.ConversationPropagator.activateConversationIfNeeded(ConversationPropagator.java:147)
      at org.apache.wicket.cdi.ConversationPropagator.onRequestHandlerResolved(ConversationPropagator.java:123)
      at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
      at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
      at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
      at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
      at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
      at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
      at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
      at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
      at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
      at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
      at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
      at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
      at org.apache.wicket.request.cycle.RequestCycle.execute(RequestCycle.java:253)
      at org.apache.wicket.request.cycle.RequestCycle.processRequest(RequestCycle.java:211)
      at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(RequestCycle.java:282)
      at org.apache.wicket.protocol.http.WicketFilter.processRequestCycle(WicketFilter.java:244)
      at org.apache.wicket.protocol.http.WicketFilter.processRequest(WicketFilter.java:188)
      at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:267)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
      at org.apache.tomee.catalina.OpenEJBValve.invoke(OpenEJBValve.java:45)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
      at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
      at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
      at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
      at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      at java.lang.Thread.run(Thread.java:722)

      We can either wait till the 3.2.0.Final gets cut, force dependency to 3.2.0-SNAPSHOT and provide jboss snapshot repository definition in our poms or influence somehow that 3.1.1 release be prepared.

        Issue Links

          Activity

          Dominik Drzewiecki created issue -
          Dominik Drzewiecki made changes -
          Field Original Value New Value
          Description It is not particularly Wicket-CDI fault to not support the latest OpenWebBeans, but rather seam-conversation-owb-3.0.0.Final, thus this issue is reported as a "wish". Seam-conversation-owb-3.0.0 depends on ancient OpenWebBeans version, although I've seen some activity in its git repositories and 3.2.0 Snapshots seem to depend on OWB 1.1.5 (AFAIR). It seems that ConversationManager.getInstance() is no longer there which results in the following stacktrace when run on tomee 1.5.1 or tomcat + OWB 1.1.7:

          SEVERE: Servlet.service() for servlet [default] in context with path [/wcjs-web] threw exception [Filter execution threw an exception] with root cause
          java.lang.NoSuchMethodError: org.apache.webbeans.conversation.ConversationManager.getInstance()Lorg/apache/webbeans/conversation/ConversationManager;
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansSeamConversationManager.doActivate(OpenWebBeansSeamConversationManager.java:41)
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansHttpSeamConversationContext.doActivate(OpenWebBeansHttpSeamConversationContext.java:44)
          at org.jboss.seam.conversation.api.AbstractSeamConversationContext.activate(AbstractSeamConversationContext.java:54)
          at org.apache.wicket.cdi.CdiContainer.activateConversationalContext(CdiContainer.java:94)
          at org.apache.wicket.cdi.ConversationPropagator.activateConversationIfNeeded(ConversationPropagator.java:147)
          at org.apache.wicket.cdi.ConversationPropagator.onRequestHandlerResolved(ConversationPropagator.java:123)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycle.execute(RequestCycle.java:253)
          at org.apache.wicket.request.cycle.RequestCycle.processRequest(RequestCycle.java:211)
          at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(RequestCycle.java:282)
          at org.apache.wicket.protocol.http.WicketFilter.processRequestCycle(WicketFilter.java:244)
          at org.apache.wicket.protocol.http.WicketFilter.processRequest(WicketFilter.java:188)
          at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:267)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
          at org.apache.tomee.catalina.OpenEJBValve.invoke(OpenEJBValve.java:45)
          at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
          at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
          at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
          at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
          at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
          at java.lang.Thread.run(Thread.java:722)

          We can either wait till the 3.2.0.Final gets cut, force dependency to 3.2.0-SNAPSOT and provide jboss snapshot repository definition in our poms or influence somehow that 3.1.1 release be prepared.
          It is not particularly Wicket-CDI fault to not support the latest OpenWebBeans, but rather seam-conversation-owb-3.0.0.Final, thus this issue is reported as a "wish". Seam-conversation-owb-3.0.0 depends on ancient OpenWebBeans version, although I've seen some activity in its git repositories and 3.2.0 Snapshots seem to depend on OWB 1.1.5 (AFAIR). It seems that ConversationManager.getInstance() is no longer there which results in the following stacktrace when run on tomee 1.5.1 or tomcat + OWB 1.1.7:

          SEVERE: Servlet.service() for servlet [default] in context with path [/wcjs-web] threw exception [Filter execution threw an exception] with root cause
          java.lang.NoSuchMethodError: org.apache.webbeans.conversation.ConversationManager.getInstance()Lorg/apache/webbeans/conversation/ConversationManager;
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansSeamConversationManager.doActivate(OpenWebBeansSeamConversationManager.java:41)
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansHttpSeamConversationContext.doActivate(OpenWebBeansHttpSeamConversationContext.java:44)
          at org.jboss.seam.conversation.api.AbstractSeamConversationContext.activate(AbstractSeamConversationContext.java:54)
          at org.apache.wicket.cdi.CdiContainer.activateConversationalContext(CdiContainer.java:94)
          at org.apache.wicket.cdi.ConversationPropagator.activateConversationIfNeeded(ConversationPropagator.java:147)
          at org.apache.wicket.cdi.ConversationPropagator.onRequestHandlerResolved(ConversationPropagator.java:123)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycle.execute(RequestCycle.java:253)
          at org.apache.wicket.request.cycle.RequestCycle.processRequest(RequestCycle.java:211)
          at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(RequestCycle.java:282)
          at org.apache.wicket.protocol.http.WicketFilter.processRequestCycle(WicketFilter.java:244)
          at org.apache.wicket.protocol.http.WicketFilter.processRequest(WicketFilter.java:188)
          at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:267)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
          at org.apache.tomee.catalina.OpenEJBValve.invoke(OpenEJBValve.java:45)
          at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
          at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
          at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
          at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
          at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
          at java.lang.Thread.run(Thread.java:722)

          We can either wait till the 3.2.0.Final gets cut, force dependency to 3.2.0-SNAPSHOT and provide jboss snapshot repository definition in our poms or influence somehow that 3.1.1 release be prepared.
          Dominik Drzewiecki made changes -
          Description It is not particularly Wicket-CDI fault to not support the latest OpenWebBeans, but rather seam-conversation-owb-3.0.0.Final, thus this issue is reported as a "wish". Seam-conversation-owb-3.0.0 depends on ancient OpenWebBeans version, although I've seen some activity in its git repositories and 3.2.0 Snapshots seem to depend on OWB 1.1.5 (AFAIR). It seems that ConversationManager.getInstance() is no longer there which results in the following stacktrace when run on tomee 1.5.1 or tomcat + OWB 1.1.7:

          SEVERE: Servlet.service() for servlet [default] in context with path [/wcjs-web] threw exception [Filter execution threw an exception] with root cause
          java.lang.NoSuchMethodError: org.apache.webbeans.conversation.ConversationManager.getInstance()Lorg/apache/webbeans/conversation/ConversationManager;
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansSeamConversationManager.doActivate(OpenWebBeansSeamConversationManager.java:41)
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansHttpSeamConversationContext.doActivate(OpenWebBeansHttpSeamConversationContext.java:44)
          at org.jboss.seam.conversation.api.AbstractSeamConversationContext.activate(AbstractSeamConversationContext.java:54)
          at org.apache.wicket.cdi.CdiContainer.activateConversationalContext(CdiContainer.java:94)
          at org.apache.wicket.cdi.ConversationPropagator.activateConversationIfNeeded(ConversationPropagator.java:147)
          at org.apache.wicket.cdi.ConversationPropagator.onRequestHandlerResolved(ConversationPropagator.java:123)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycle.execute(RequestCycle.java:253)
          at org.apache.wicket.request.cycle.RequestCycle.processRequest(RequestCycle.java:211)
          at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(RequestCycle.java:282)
          at org.apache.wicket.protocol.http.WicketFilter.processRequestCycle(WicketFilter.java:244)
          at org.apache.wicket.protocol.http.WicketFilter.processRequest(WicketFilter.java:188)
          at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:267)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
          at org.apache.tomee.catalina.OpenEJBValve.invoke(OpenEJBValve.java:45)
          at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
          at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
          at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
          at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
          at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
          at java.lang.Thread.run(Thread.java:722)

          We can either wait till the 3.2.0.Final gets cut, force dependency to 3.2.0-SNAPSHOT and provide jboss snapshot repository definition in our poms or influence somehow that 3.1.1 release be prepared.
          It is not particularly Wicket-CDI fault to not support the latest OpenWebBeans, but rather seam-conversation-owb-3.0.0.Final, thus this issue is reported as a "wish". Seam-conversation-owb-3.0.0 depends on ancient OpenWebBeans version, although I've seen some activity in its git repositories (https://github.com/seam/conversation/commit/a5f2e3f42829f8405e6bee6caab43fd034e5be81) and 3.2.0 Snapshots deployed to jboss maven repo seem to depend on OWB 1.1.5 (AFAIR). It seems that ConversationManager.getInstance() is no longer there which results in the following stacktrace when run on tomee 1.5.1 or tomcat + OWB 1.1.7:

          SEVERE: Servlet.service() for servlet [default] in context with path [/wcjs-web] threw exception [Filter execution threw an exception] with root cause
          java.lang.NoSuchMethodError: org.apache.webbeans.conversation.ConversationManager.getInstance()Lorg/apache/webbeans/conversation/ConversationManager;
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansSeamConversationManager.doActivate(OpenWebBeansSeamConversationManager.java:41)
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansHttpSeamConversationContext.doActivate(OpenWebBeansHttpSeamConversationContext.java:44)
          at org.jboss.seam.conversation.api.AbstractSeamConversationContext.activate(AbstractSeamConversationContext.java:54)
          at org.apache.wicket.cdi.CdiContainer.activateConversationalContext(CdiContainer.java:94)
          at org.apache.wicket.cdi.ConversationPropagator.activateConversationIfNeeded(ConversationPropagator.java:147)
          at org.apache.wicket.cdi.ConversationPropagator.onRequestHandlerResolved(ConversationPropagator.java:123)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycle.execute(RequestCycle.java:253)
          at org.apache.wicket.request.cycle.RequestCycle.processRequest(RequestCycle.java:211)
          at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(RequestCycle.java:282)
          at org.apache.wicket.protocol.http.WicketFilter.processRequestCycle(WicketFilter.java:244)
          at org.apache.wicket.protocol.http.WicketFilter.processRequest(WicketFilter.java:188)
          at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:267)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
          at org.apache.tomee.catalina.OpenEJBValve.invoke(OpenEJBValve.java:45)
          at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
          at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
          at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
          at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
          at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
          at java.lang.Thread.run(Thread.java:722)

          We can either wait till the 3.2.0.Final gets cut, force dependency to 3.2.0-SNAPSHOT and provide jboss snapshot repository definition in our poms or influence somehow that 3.1.1 release be prepared.
          Dominik Drzewiecki made changes -
          Description It is not particularly Wicket-CDI fault to not support the latest OpenWebBeans, but rather seam-conversation-owb-3.0.0.Final, thus this issue is reported as a "wish". Seam-conversation-owb-3.0.0 depends on ancient OpenWebBeans version, although I've seen some activity in its git repositories (https://github.com/seam/conversation/commit/a5f2e3f42829f8405e6bee6caab43fd034e5be81) and 3.2.0 Snapshots deployed to jboss maven repo seem to depend on OWB 1.1.5 (AFAIR). It seems that ConversationManager.getInstance() is no longer there which results in the following stacktrace when run on tomee 1.5.1 or tomcat + OWB 1.1.7:

          SEVERE: Servlet.service() for servlet [default] in context with path [/wcjs-web] threw exception [Filter execution threw an exception] with root cause
          java.lang.NoSuchMethodError: org.apache.webbeans.conversation.ConversationManager.getInstance()Lorg/apache/webbeans/conversation/ConversationManager;
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansSeamConversationManager.doActivate(OpenWebBeansSeamConversationManager.java:41)
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansHttpSeamConversationContext.doActivate(OpenWebBeansHttpSeamConversationContext.java:44)
          at org.jboss.seam.conversation.api.AbstractSeamConversationContext.activate(AbstractSeamConversationContext.java:54)
          at org.apache.wicket.cdi.CdiContainer.activateConversationalContext(CdiContainer.java:94)
          at org.apache.wicket.cdi.ConversationPropagator.activateConversationIfNeeded(ConversationPropagator.java:147)
          at org.apache.wicket.cdi.ConversationPropagator.onRequestHandlerResolved(ConversationPropagator.java:123)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycle.execute(RequestCycle.java:253)
          at org.apache.wicket.request.cycle.RequestCycle.processRequest(RequestCycle.java:211)
          at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(RequestCycle.java:282)
          at org.apache.wicket.protocol.http.WicketFilter.processRequestCycle(WicketFilter.java:244)
          at org.apache.wicket.protocol.http.WicketFilter.processRequest(WicketFilter.java:188)
          at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:267)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
          at org.apache.tomee.catalina.OpenEJBValve.invoke(OpenEJBValve.java:45)
          at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
          at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
          at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
          at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
          at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
          at java.lang.Thread.run(Thread.java:722)

          We can either wait till the 3.2.0.Final gets cut, force dependency to 3.2.0-SNAPSHOT and provide jboss snapshot repository definition in our poms or influence somehow that 3.1.1 release be prepared.
          It is not particularly Wicket-CDI fault to not support the latest OpenWebBeans, but rather seam-conversation-owb-3.0.0.Final, thus this issue is reported as a "wish". Seam-conversation-owb-3.0.0 depends on ancient OpenWebBeans version, although I've seen some activity in its git repositories (https://github.com/seam/conversation/commit/a5f2e3f42829f8405e6bee6caab43fd034e5be81) and 3.2.0 Snapshots deployed to jboss maven repo (https://repository.jboss.org/nexus/content/groups/public/org/jboss/seam/conversation/seam-conversation-owb/3.2.0-SNAPSHOT/) seem to depend on OWB 1.1.3. It seems that ConversationManager.getInstance() is no longer there which results in the following stacktrace when run on tomee 1.5.1 or tomcat + OWB 1.1.7:

          SEVERE: Servlet.service() for servlet [default] in context with path [/wcjs-web] threw exception [Filter execution threw an exception] with root cause
          java.lang.NoSuchMethodError: org.apache.webbeans.conversation.ConversationManager.getInstance()Lorg/apache/webbeans/conversation/ConversationManager;
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansSeamConversationManager.doActivate(OpenWebBeansSeamConversationManager.java:41)
          at org.jboss.seam.conversation.plugins.openwebbeans.OpenWebBeansHttpSeamConversationContext.doActivate(OpenWebBeansHttpSeamConversationContext.java:44)
          at org.jboss.seam.conversation.api.AbstractSeamConversationContext.activate(AbstractSeamConversationContext.java:54)
          at org.apache.wicket.cdi.CdiContainer.activateConversationalContext(CdiContainer.java:94)
          at org.apache.wicket.cdi.ConversationPropagator.activateConversationIfNeeded(ConversationPropagator.java:147)
          at org.apache.wicket.cdi.ConversationPropagator.onRequestHandlerResolved(ConversationPropagator.java:123)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:155)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection$5.notify(RequestCycleListenerCollection.java:151)
          at org.apache.wicket.util.listener.ListenerCollection.notify(ListenerCollection.java:80)
          at org.apache.wicket.request.cycle.RequestCycleListenerCollection.onRequestHandlerResolved(RequestCycleListenerCollection.java:150)
          at org.apache.wicket.request.cycle.RequestCycle.execute(RequestCycle.java:253)
          at org.apache.wicket.request.cycle.RequestCycle.processRequest(RequestCycle.java:211)
          at org.apache.wicket.request.cycle.RequestCycle.processRequestAndDetach(RequestCycle.java:282)
          at org.apache.wicket.protocol.http.WicketFilter.processRequestCycle(WicketFilter.java:244)
          at org.apache.wicket.protocol.http.WicketFilter.processRequest(WicketFilter.java:188)
          at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:267)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:222)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
          at org.apache.tomee.catalina.OpenEJBValve.invoke(OpenEJBValve.java:45)
          at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:99)
          at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:936)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
          at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1004)
          at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589)
          at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
          at java.lang.Thread.run(Thread.java:722)

          We can either wait till the 3.2.0.Final gets cut, force dependency to 3.2.0-SNAPSHOT and provide jboss snapshot repository definition in our poms or influence somehow that 3.1.1 release be prepared.
          Dominik Drzewiecki added a comment -

          I filed an issue at jboss : https://issues.jboss.org/browse/SEAM-142, but I doubt it will get resolved soon (the activity of this project makes me think it is dead)

          Martin Grigorov added a comment -

          AFAIK they merged forces with http://incubator.apache.org/deltaspike/

          Dominik Drzewiecki added a comment - - edited

          Maybe wicket-cdi should no longer depend on seam (which is pretty dead) and we should consider switching to deltaspike, even though it is still in incubation stage? They even deployed to central repo 0.3-incubating version of artifacts which seem to host the functionality their seam-based counterparts do (http://search.maven.org/#search%7Cga%7C1%7Cg%3A%22org.apache.deltaspike.cdictrl%22).

          Martin Grigorov added a comment -

          There was a discussion in dev@wicket.apache.org about this.
          Mark Struberg (from DeltaSpike) also suggested this, but Igor Vaynberg (the creator of wicket-cdi) explained that Seam provides functionalities which are not yet available in DeltaSpike, like the conversations support. I think this is the main reason to depend on Weld.

          See http://markmail.org/thread/elmrj567pgyq2i4l

          Dominik Drzewiecki added a comment -

          Can't acces markmail at the moment, but I suppose you are referring to this very thread: http://apache-wicket.1842946.n4.nabble.com/announce-Wicket-CDI-for-Wicket-6-0-0-released-td4651925.html. Igor explained that thanks to the seam-conversation-spi wicket-cdi does not directly depend on weld, and thus can be easily run against different CDI impls (using seam-conversation-weld, seam-conversation-owb, seam-conversation-candi). The problem is - seam-conversation along the whole seam seems pretty dead. Thus my proposal to replace seam-conversation-spi with deltaspike-cdictrl-api. Mark Struberg was partially right that wicket-cdi at its current state prevents wicket based apps from being run in the "Apache realm" - due to lack of support from seam-converasation-owb we are restricted to run on OWB 1.0 (I suppose nobody any longer use it).

          Martin Grigorov added a comment -
          Dominik Drzewiecki added a comment -

          Thanks for the link. I don't get the whole point of mandatory seam dependency. A glimpse at org.apache.deltaspike.cdise.api.ContextControl implementations (org.apache.deltaspike.cdise.owb.OpenWebBeansContextControl and org.apache.deltaspike.cdise.weld.WeldContextControl) reveals that both support ConversationScope, which usage seemed to have been a problem raised by Igor in aforementioned thread. Maybe the arguments Igor raised almost 9 month ago are no longer valid?

          Martin Grigorov added a comment -

          To get an answer for that it will be the best to ask Mark Struberg. He knows better how DeltaSpike evolved. And he was the one against the required functionality by Wicket. If Mark confirms that the needed functionality is in DeltaSpike now then we can start thinking for migration from Weld/Seam to DeltaSpike.

          Igor Vaynberg made changes -
          Assignee Igor Vaynberg [ ivaynberg ]
          Igor Vaynberg added a comment -

          cdi 1.1 provides a standardized api for managing the conversational context. we will have a new wicket-cdi-1.1 module which will utilize this standard api.

          Martin Grigorov made changes -
          Link This issue is duplicated by WICKET-5239 [ WICKET-5239 ]
          Martin Grigorov made changes -
          Remote Link This issue links to "Discussion in dev@ about wicket-cdi-1.1 (Web Link)" [ 12350 ]
          Martin Grigorov added a comment -

          I just pushed branch 'cdi-1.1' that has an additional module wicket-cdi-1.1 as discussed recently in the mailing lists.
          With my non-existent experience with CDI I cannot see how CDI 1.1 conversations will work transparently for all CDI implementations.
          The Context implementations which have #(de)activate() and #(dis|as)sociate(HttpServletRequest) methods are in Weld, not in javax.enterprise:cdi-api.

          Maybe we will need modules: wicket-cdi-1.1-base, wicket-cdi-1.1-weld, wicket-cdi-1.1-owb, ... Like the ones for Native WebSocket.

          Martin Grigorov added a comment - - edited

          https://github.com/apache/wicket/pull/44 suggests a custom annotation (CdiAware) that should be used on any component, behavior, application and session which need CDI injection.
          Glassfish 4 (or Weld 2.0) logs warnings when trying to process an object without default constructor, e.g. all Components need the component id and this leads to many warnings in the log.
          Take this PR into account when working on this ticket.

          John Sarman added a comment -

          I am testing the cdi-1.1 branch. So far I merged the upstream changes to the branch,changed the dependency to cdi-1.1 and removed the seam dependency. I then removed all the seam calls. What I have observed is that the conversation is injected simply with the @Inject tag and simply placing the @ConversationScoped on a class that is managed by the app server, in my case Glassfish4, is all that is needed. This means that the setPropegation() configuration is not needed. As for activate and deactivate the app server seems to manage this now. I am going to continue experimenting to look for any caveats, but so far all is well with the exception that Wicket is instantiating my page twice and causing my demo app to call my conversation scoped bean twice per page load. I think Igor needs to comment on the propagation config importance and any other thoughts that may help move this forward.

          Igor Vaynberg added a comment -

          John Sarman i dont think that is exactly correct. cdi-1.1 automatically starts a conversation around each servlet request, so wicket doesnt need to do that. however, the propagation wont work automatically. for example you first hit a page, its rendered in conversation A. when you click a link on that page it will execute in a conversation, but that conversation may not be A. wicket's propagation makes sure that a page has a consistent long running conversation if one is requested.

          John Sarman added a comment -

          Currently I am passing the cid in the pageparameters and calling
          conversation.begin myself. So I guess I am manually handling the
          conversation long running setup myself. I will investigate the
          propagation code
          next to let wicket do the managing of conversations.

          Martin Grigorov made changes -
          Fix Version/s 7.0.0 [ 12322958 ]
          Martin Grigorov added a comment -

          I guess this is fixed now with the new wicket-cdi-1.1 module.
          Please try once Wicket 6.13 is released and let us know.

          Martin Grigorov made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Assignee Igor Vaynberg [ ivaynberg ] Emond Papegaaij [ papegaaij ]
          Fix Version/s 6.13.0 [ 12325564 ]
          Resolution Fixed [ 1 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          344d 3h 38m 1 Martin Grigorov 17/Dec/13 13:19

            People

            • Assignee:
              Emond Papegaaij
              Reporter:
              Dominik Drzewiecki
            • Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development