Wicket
  1. Wicket
  2. WICKET-4835

Add debug log messages in CompoundRequestMapper#mapRequest

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 6.0.0
    • Fix Version/s: 1.5.9, 6.3.0
    • Component/s: wicket
    • Labels:

      Description

      When there is need for very complex URL mappings it would be handy to have debug log messages written in CompoundRequestMapper#mapRequest(Request), e.g. logging mapperWithScore.toString() for all mappers having a score greater than 0.

      Currently, the best way to debug unexpected behavior with mappings is to attach the wicket sources, put a breakpoint after Collections.sort(list) and inspect the list using the IDE.

        Activity

        Peter Parson created issue -
        Martin Grigorov added a comment -

        Since you have the sources around can you please attach a patch ?

        Peter Parson added a comment -

        Patch for debug log messages in CompundRequestMapper (untested)

        Peter Parson made changes -
        Field Original Value New Value
        Attachment CompoundRequestMapper-debug-logging.patch [ 12550626 ]
        Peter Parson added a comment -

        Sure, I have just attached it. However I am currently not able to test it, sorry.

        Martin Grigorov made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Martin Grigorov [ mgrigorov ]
        Fix Version/s 6.3.0 [ 12323327 ]
        Fix Version/s 1.5.9 [ 12322962 ]
        Resolution Fixed [ 1 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        9d 2h 40m 1 Martin Grigorov 02/Nov/12 15:26

          People

          • Assignee:
            Martin Grigorov
            Reporter:
            Peter Parson
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development