Wicket
  1. Wicket
  2. WICKET-4797

CheckBoxMultipleChoice loses state

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.2.0
    • Fix Version/s: 6.2.0
    • Component/s: wicket
    • Labels:
      None

      Description

      At 6.2.0-SNAPSHOT the CheckBoxMultipleChoice component looses its current selection of options every time a new one is selected. Initial investigation/debug shows that the converted input already don't have the full user selection, so the root cause may be a bug in the encode/decoding of the request parameters.
      It's a regression since the same quickstart works fine at 6.0.0

      1. quickstart.zip
        26 kB
        Pedro Santos

        Issue Links

          Activity

          Pedro Santos added a comment -

          just tested the quickstart at 6.1.0 and it's OK, the but is at the 6.2.0-SNAPSHOT only


            People

            • Assignee:
              Sven Meier
              Reporter:
              Pedro Santos
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development