Wicket
  1. Wicket
  2. WICKET-4773

ComponentFeedbackPanel broken under Wicket 6.0.0 when RenderStrategy.REDIRECT_TO_RENDER

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.0.0
    • Fix Version/s: 6.1.0
    • Component/s: None
    • Labels:
      None

      Description

      Test case created on github, see https://github.com/danhaywood/wicket-4773

      browse to http://localhost:8080/wicket-examples/forminput and follow the instructions.

        Activity

        Emond Papegaaij made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Emond Papegaaij added a comment -

        The code that clears the reporter was added long ago for WICKET-2384 to prevent a memory leak. I'm not sure if this is still needed, but it seems better to at least not clear reporter until the message is rendered.

        Emond Papegaaij made changes -
        Assignee Emond Papegaaij [ papegaaij ]
        Martin Grigorov made changes -
        Fix Version/s 6.1.0 [ 12322957 ]
        Dan Haywood added a comment -

        The issue is that the reporter on the FeedbackMessage is set to null when detached after the first request; this means that the ComponentFeedbackPanel's filter never locates the message on the rendering in the second request

        Dan Haywood made changes -
        Field Original Value New Value
        Description Test case created on github. Test case created on github, see https://github.com/danhaywood/wicket-4773

        browse to http://localhost:8080/wicket-examples/forminput and follow the instructions.
        Dan Haywood created issue -

          People

          • Assignee:
            Emond Papegaaij
            Reporter:
            Dan Haywood
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development