Wicket
  1. Wicket
  2. WICKET-4656

Atmosphere example doesn't work due to missing 'page' when creating AjaxRequestTarget

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 6.0.0-beta3
    • Fix Version/s: 6.1.0
    • Component/s: wicket-atmosphere
    • Labels:
      None

      Description

      Testing beta3 revealed this error when trying to use Wicket Atmosphere:

      ERROR - DefaultExceptionMapper - Unexpected error occurred
      java.lang.IllegalArgumentException: Argument 'page' may not be null.
      at org.apache.wicket.util.lang.Args.notNull(Args.java:41)
      at org.apache.wicket.ajax.AjaxRequestHandler.<init>(AjaxRequestHandler.java:111)
      at org.apache.wicket.protocol.http.WebApplication$DefaultAjaxRequestTargetProvider.get(WebApplication.java:956)
      at org.apache.wicket.protocol.http.WebApplication$DefaultAjaxRequestTargetProvider.get(WebApplication.java:949)
      at org.apache.wicket.protocol.http.WebApplication.newAjaxRequestTarget(WebApplication.java:800)
      at org.apache.wicket.atmosphere.AtmosphereRequestHandler.respond(AtmosphereRequestHandler.java:65)
      at org.apache.wicket.request.cycle.RequestCycle$HandlerExecutor.respond(RequestCycle.java:814)
      at org.apache.wicket.request.RequestHandlerStack.execute(RequestHandlerStack.java:64)
      ....

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        64d 13h 50m 1 Emond Papegaaij 17/Sep/12 06:37
        Emond Papegaaij made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 6.1.0 [ 12322957 ]
        Resolution Fixed [ 1 ]
        Emond Papegaaij added a comment -

        This is fixed with more recent versions of Atmosphere.

        Emond Papegaaij added a comment -

        This seems to be caused by a bug in Jetty 7.6.3 (which is used for the examples), Jetty 8.1.3 works fine.

        Emond Papegaaij added a comment - - edited

        This seems to be caused by the upgrade to Atmosphere 1.0.0-beta3. I've reported an issue ( https://github.com/Atmosphere/atmosphere/issues/513 ). For now, you can work around the problem by forcing atmosphere to version 0.9.5 using maven dependency management (0.9.6 and 0.9.7 are broken as well).

        Martin Grigorov created issue -

          People

          • Assignee:
            Emond Papegaaij
            Reporter:
            Martin Grigorov
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development