Wicket
  1. Wicket
  2. WICKET-4084

AutoComplete text field inside a modal window displays drop-down in the wrong location if the page is scrolled

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4.18
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      I have a page that contains a ModalWindow. That ModalWindow contains an AutoCompleteTextField.
      If the main page has a lot of content, the AutoCompleteTextField only works correctly if the page is scrolled to the top.
      You can see this easily by scrolling the page up and down while the ModalWindow is open and the AutoCompleteTextField is showing its dropdown.

      I believe what is happening is that the dropdown has an absolute position relative to the Page, rather than relative to the ModalWindow. When you scroll the page down, the dropdown remains in the same position on the page (and hence scrolls off the top), while the ModalWindow stays in the same position on the screen.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          814d 15h 13m 1 Andrea Del Bene 18/Dec/13 19:02
          Andrea Del Bene added a comment -

          Wow! How many of them !

          Andrea Del Bene made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Andrea Del Bene made changes -
          Link This issue is duplicated by WICKET-4294 [ WICKET-4294 ]
          Martin Grigorov added a comment -

          Andrea Del Bene Could you please check this ticket too ?
          Thanks!

          Martin Grigorov made changes -
          Assignee Johan Compagner [ jcompagner ] Andrea Del Bene [ bitstorm ]
          Martin Grigorov made changes -
          Assignee Johan Compagner [ jcompagner ]
          Cedric Gatay added a comment -

          I can reproduce this too using the Quickstart, I corrected the Quickstart to use Wicket 1.4.19 instead of SNAPSHOT though. It seems wicket-autocomplete.js attach the autocomplete element at the wrong place, I think it should be appended next to the textfield it replaces instead.

          Alex Grant added a comment -

          This does appear to be similar to WICKET-1355, which was closed as Can't Reproduce. But I can reproduce this one consistently (as per the quickstart).

          Alex Grant made changes -
          Field Original Value New Value
          Attachment WICKET-4084-autocomplete.zip [ 12496435 ]
          Alex Grant added a comment - - edited

          Attached a quickstart, WICKET-4084-autocomplete.zip.

          Alex Grant created issue -

            People

            • Assignee:
              Andrea Del Bene
              Reporter:
              Alex Grant
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development