Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.3.4
    • Fix Version/s: 1.3.5
    • Component/s: wicket
    • Labels:
      None
    • Environment:
      Any

      Description

      With latest trunk, the following message occurs in the logs:

      09:41:50.297 ERROR [org.apache.wicket.markup.html.WebPage ] - ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
      09:41:50.314 ERROR [org.apache.wicket.markup.html.WebPage ] - You probably forgot to add a <body> or <header> tag to your markup since no Header Container was found but components where found which want to write to the <head> section.

      This happens, when using TransparentResolver with the html-Tag.

      A quickstart is attached.

        Activity

        Jan Kriesten created issue -
        Jan Kriesten made changes -
        Field Original Value New Value
        Attachment issue-quickstart.zip [ 12382826 ]
        Frank Bille Jensen made changes -
        Assignee Igor Vaynberg [ ivaynberg ]
        Frank Bille Jensen added a comment -

        Could it be related to WICKET-1682?

        Martijn Dashorst made changes -
        Fix Version/s 1.3.5 [ 12313175 ]
        Fix Version/s 1.3.4 [ 12313089 ]
        Igor Vaynberg added a comment -

        juergen, there is a todo in there for you? webpage:449

        Igor Vaynberg made changes -
        Assignee Igor Vaynberg [ ivaynberg ] Juergen Donnerstag [ jdonnerstag ]
        Igor Vaynberg added a comment -

        i just committed a fix for this particular usecase. juergen, you should still look at the todo and if nothing is there feel free to close this one.

        Igor Vaynberg added a comment -

        could not reproduce with latest branch and trunk. must already be fixed.

        Igor Vaynberg made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Juergen Donnerstag [ jdonnerstag ] Igor Vaynberg [ ivaynberg ]
        Resolution Cannot Reproduce [ 5 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        122d 22h 27m 1 Igor Vaynberg 27/Sep/08 06:15

          People

          • Assignee:
            Igor Vaynberg
            Reporter:
            Jan Kriesten
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development