Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.2
    • Fix Version/s: 0.8.2, 0.9.0
    • Component/s: core
    • Labels:
      None

      Description

      Karaf itests are failing on trunk and branch-0.8.

        Issue Links

          Activity

          abayer Andrew Bayer added a comment -

          Fixed by WHIRR-670.

          abayer Andrew Bayer added a comment -

          Oh, I did do a mvn clean install -DskipTests -Posgi from the top level before running the tests. Don't know if that would make a difference.

          abayer Andrew Bayer added a comment -

          Oh, I believe it. No idea why it passes for me with the patch, but this karaf stuff is just strange to me...I'll poke at it more tomorrow.

          adriancole Adrian Cole added a comment -

          I tried this even after wiping.. sorry.

          $ mvn -version
          Apache Maven 3.0.4 (r1232337; 2012-01-17 00:44:56-0800)
          Maven home: /usr/local/Cellar/maven/3.0.4/libexec
          Java version: 1.6.0_43, vendor: Apple Inc.
          Java home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
          Default locale: en_US, platform encoding: MacRoman
          OS name: "mac os x", version: "10.8.3", arch: "x86_64", family: "mac"

          $ git status

          1. On branch branch-0.8
          2. Changes not staged for commit:
          3. (use "git add <file>..." to update what will be committed)
          4. (use "git checkout – <file>..." to discard changes in working directory)
            #
          5. modified: platforms/karaf/feature/pom.xml
          6. modified: platforms/karaf/feature/src/main/resources/features.xml
            #

          $ mvn clean verify -Posgi
          -snip-
          rg.ops4j.pax.exam.TestContainerException: [testServices(org.apache.whirr.karaf.itest.WhirrFunctionLoaderTest): org/jclouds/scriptbuilder/functionloader/osgi/ServiceFunctionLoader]
          at org.ops4j.pax.exam.invoker.junit.internal.JUnitProbeInvoker.invokeViaJUnit(JUnitProbeInvoker.java:112)
          at org.ops4j.pax.exam.invoker.junit.internal.JUnitProbeInvoker.findAndInvoke(JUnitProbeInvoker.java:89)
          at org.ops4j.pax.exam.invoker.junit.internal.JUnitProbeInvoker.call(JUnitProbeInvoker.java:72)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.ops4j.pax.exam.rbc.internal.RemoteBundleContextImpl.remoteCall(RemoteBundleContextImpl.java:86)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:303)
          at sun.rmi.transport.Transport$1.run(Transport.java:159)
          at java.security.AccessController.doPrivileged(Native Method)
          at sun.rmi.transport.Transport.serviceCall(Transport.java:155)
          at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:535)
          at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:790)
          at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:649)
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
          at java.lang.Thread.run(Thread.java:680)
          Caused by: java.lang.NoClassDefFoundError: org/jclouds/scriptbuilder/functionloader/osgi/ServiceFunctionLoader
          at org.apache.whirr.karaf.itest.WhirrFunctionLoaderTest.testServices(WhirrFunctionLoaderTest.java:45)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:597)
          at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:45)
          at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
          at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:42)
          at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
          at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:263)
          at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:68)
          at org.ops4j.pax.exam.invoker.junit.internal.ContainerTestRunner.runChild(ContainerTestRunner.java:58)
          at org.ops4j.pax.exam.invoker.junit.internal.ContainerTestRunner.runChild(ContainerTestRunner.java:32)
          at org.junit.runners.ParentRunner$3.run(ParentRunner.java:231)
          at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:60)
          at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:229)
          at org.junit.runners.ParentRunner.access$000(ParentRunner.java:50)
          at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:222)
          at org.junit.runners.ParentRunner.run(ParentRunner.java:300)
          at org.junit.runner.JUnitCore.run(JUnitCore.java:157)
          at org.junit.runner.JUnitCore.run(JUnitCore.java:136)
          at org.ops4j.pax.exam.invoker.junit.internal.JUnitProbeInvoker.invokeViaJUnit(JUnitProbeInvoker.java:108)
          ... 21 more
          Caused by: java.lang.ClassNotFoundException: org.jclouds.scriptbuilder.functionloader.osgi.ServiceFunctionLoader not found by PAXEXAM-PROBE-d6bf92ae-186b-485d-a74f-60ed1df56474 [56]
          at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:787)
          at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:71)
          at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1768)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

          -snip-

          abayer Andrew Bayer added a comment -

          So from what I could tell, we needed to bump the jclouds.karaf.version and add a couple new bundle dependencies - or at least that, combined with nuking ~/.m2/repository/org/apache/whirr - was what it took for the tests to pass for me locally, when run with "mvn clean verify -Posgi"

          abayer Andrew Bayer added a comment -

          Test failures attached.


            People

            • Assignee:
              abayer Andrew Bayer
              Reporter:
              abayer Andrew Bayer
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development