Uploaded image for project: 'Apache Whirr (retired)'
  1. Apache Whirr (retired)
  2. WHIRR-514

Update release instructions or fix update-version script?

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 0.8.0
    • Component/s: documentation
    • Labels:
      None

      Description

      The update-versions script doesn't handle modules without a /project/parent/version element (the build-tools module doesn't have one).

      karel@tomato:~/work/whirr$ ruby build-tools/update-versions 12345
      Updating to version 12345 ...
      build-tools/update-versions:61:in `process_module': undefined method `inner_html=' for nil:NilClass (NoMethodError)
      from build-tools/update-versions:54:in `edit_pom'
      from build-tools/update-versions:60:in `process_module'
      from build-tools/update-versions:73
      from build-tools/update-versions:73:in `each'
      from build-tools/update-versions:73
      from build-tools/update-versions:54:in `edit_pom'
      from build-tools/update-versions:67

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              karel1980 Karel Vervaeke
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: