Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.7.0
    • Component/s: None
    • Labels:
      None

      Description

      Jclouds 1.2.1 was released today.

      1. WHIRR-400.patch
        6 kB
        Adrian Cole
      2. WHIRR-400.patch
        6 kB
        Andrei Savu
      3. WHIRR-400.patch
        14 kB
        Andrei Savu

        Issue Links

          Activity

          Andrei Savu added a comment -

          Committed. Thanks guys for looking into this!

          Andrei Savu added a comment -

          The test is passing with the Amazon Linux AMI [1] ami-7f418316 (EBS-Backed 32-bit) on t1.micro. I will go ahead and commit this change because the failure is unrelated to jclouds 1.2.1 (I'm seeing the same failure in trunk) and I will open a new issue to investigate how we can make the image selection process more robust for Amazon EC2. The test is also passing on cloudservers-us.

          The strange thing is that everything was working fine a few days ago.

          [1] http://aws.amazon.com/amazon-linux-ami/

          Andrei Savu added a comment -

          Karel I'm also suspecting this is an Amazon or AMI issue because the same test was working a few days ago.

          Karel Vervaeke added a comment -

          I've been having the same problem lately. You could also test with machines in another zone/region.

          Adrian Cole added a comment -

          also, you can try a different image id.

          Andrei Savu added a comment -

          I'm seeing the same error. I will make the suggested change and try again.

          Adrian Cole added a comment -

          There's a socket timeout at the root of the below stacktrace. I'd change the logging configuration used to trace the category "jclouds.ssh" and see what's happening. When this occurs, you can look in jclouds-wire.log to see the ssh key used and log in with it (where sha1 = keyFingerprint).

          I can't troubleshoot further, but hope this helps.

          Caused by: java.util.concurrent.ExecutionException: org.jclouds.ssh.SshException: (ubuntu:rsa[fingerprint(a7:e8:d8:8b:aa:36:e8:c0:ea:07:ba:b6:c1:44:3c:ab),
          sha1(5a:fe:9e:d5:64:52:b3:b0:d9:b9:72:5a:cc:92:04:6a:e1:0a:ec:0f)]@107.22.55.221:22) (ubuntu:rsa[fingerprint(a7:e8:d8:8b:aa:36:e8:c0:ea:07:ba:b6:c1:44:3c:a
          b),sha1(5a:fe:9e:d5:64:52:b3:b0:d9:b9:72:5a:cc:92:04:6a:e1:0a:ec:0f)]@107.22.55.221:22) error acquiring ExecResponse(command=[./setup-adriancole status]):
          Read timed out
          at com.google.common.util.concurrent.AbstractFuture$Sync.getValue(AbstractFuture.java:328)
          at com.google.common.util.concurrent.AbstractFuture$Sync.get(AbstractFuture.java:301)
          at com.google.common.util.concurrent.AbstractFuture.get(AbstractFuture.java:93)
          at org.jclouds.compute.callables.BlockUntilInitScriptStatusIsZeroThenReturnOutput.get(BlockUntilInitScriptStatusIsZeroThenReturnOutput.java:190)
          at org.jclouds.compute.callables.RunScriptOnNodeAsInitScriptUsingSshAndBlockUntilComplete.doCall(RunScriptOnNodeAsInitScriptUsingSshAndBlockUntilComplete.java:60)
          ... 8 more

          Adrian Cole added a comment -

          I'll have a look

          Andrei Savu added a comment -

          Something strange is happening because I'm unable to make the ZooKeeper integration tests to pass on Amazon EC2 (tried on two accounts) due to ssh connectivity issues (read timeouts). Everything seems to be working fine on cloudserver-us. Am I the only one seeing this?

          Andrei Savu added a comment -

          I have disabled the "Optimize imports on the fly" option.

          Tom White added a comment -

          +1 Looks good to me. Nit: imports are re-arranged in places and are not alphabetical.

          Andrei Savu added a comment -

          Updated patch to remove some classes that are now part of jclouds 1.2.1.

          Andrei Savu added a comment -

          Good to go?

          Andrei Savu added a comment -

          Updated jclouds version from 1.2.1-SNAPSHOT to 1.2.1 now that maven central is in sync.

          Andrei Savu added a comment -

          Are you sure the Nullable import change is needed? I've been able to build the project without.

          My change looks like this:

          diff --git a/pom.xml b/pom.xml
          index 8682d30..2bff0d1 100644
          --- a/pom.xml
          +++ b/pom.xml
          @@ -53,7 +53,7 @@
             </modules>
           
             <properties>
          -    <jclouds.version>1.1.1</jclouds.version>
          +    <jclouds.version>1.2.1</jclouds.version>
             </properties>
           
             <dependencyManagement>
          @@ -61,7 +61,7 @@
                 <dependency>
                   <groupId>com.google.guava</groupId>
                   <artifactId>guava</artifactId>
          -        <version>r09</version>
          +        <version>10.0.1</version>
                 </dependency>
                 <dependency>
                   <groupId>ca.juliusdavies</groupId>
          

          HBase integration tests are passing on aws-ec2 and cloudservers-us.

          Andrei Savu added a comment -

          I agree that spot instances are annoying in testing. We should probably go back at using regular instances.

          Adrian Cole added a comment -

          I can understand the desire for spot prices in our test config, but.. ehh.. spot pricing on a t1.micro is pretty close to being cheap!! we are waiting an extra 5-10m for spot to fill to save 1 penny each!!

          If we want to use spot pricing, we should set location-id to somewhere not us-east-1, and probably makes sense for larger instances.

          Adrian Cole added a comment -

          this patch, I'm testing now. Note that the code changes are all dependency-based, as jclouds no longer packages javax.annotation.Nullable due to OSGi problems.

          1.2.1-SNAPSHOT was built from jclouds 1.2.0 branch

          Andrei Savu added a comment -

          While trying to make this upgrade we found a problem with the release. I'm doing some more testing with a small change and we are going to have a hotfix jclouds release tomorrow: 1.2.1


            People

            • Assignee:
              Andrei Savu
              Reporter:
              Andrei Savu
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development