Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Not A Problem
    • Affects Version/s: 0.3.0
    • Fix Version/s: 0.3.0
    • Component/s: cli
    • Labels:
      None

      Description

      Steps to reproduce:

      $ mvn package assembly:assembly
      $ cp target/whirr-0.3.0-incubating-SNAPSHOT.tar.gz /tmp
      $ cd /tmp
      $ tar xvfz whirr-0.3.0-incubating-SNAPSHOT.tar.gz
      $ cd whirr-0.3.0-incubating-SNAPSHOT/
      $ ./bin/whirr
      ./bin/whirr: line 24: [: /tmp/whirr-0.3.0-incubating-SNAPSHOT/bin/../whirr-cli-0.3.0-incubating-SNAPSHOT.jar: binary operator expected
      No CLI JAR found.
      

      This is related to the changes made in WHIRR-156. I will provide a fix.

        Activity

        savu.andrei Andrei Savu added a comment -

        I'm closing this. No longer an issue probably thanks to changes in WHIRR-210.

        tomwhite Tom White added a comment -

        This is since WHIRR-210, I think. I'm not sure why the JAR is not longer being created, but this is the correct behaviour since we shouldn't ship all the test dependencies (which is what WHIRR-210 fixed). I'm fine with closing this issue. We might also look at making the build less brittle by excluding the test jar from the binary distribution in whirr-build-tools/src/assemble-bin.xml.

        savu.andrei Andrei Savu added a comment -

        The current trunk no longer adds the .jar with tests in the release archive. Is this the expected behavior? If so this issue should be closed.

        tomwhite Tom White added a comment -

        This is a different problem. The

        whirr-cli-*.jar
        

        glob is matching whirr-cli-0.3.0-incubating-SNAPSHOT.jar and whirr-cli-0.3.0-incubating-SNAPSHOT-tests.jar which causes it to fail. We could fix this by calling

        shopt -s extglob
        

        at the beginning of the script and then using

        !(whirr-cli-*-tests).jar
        

        as the pattern.

        savu.andrei Andrei Savu added a comment -

        I don't think so but I'm not familiar with the release process.

        tomwhite Tom White added a comment -

        Is related to WHIRR-127 (or the same problem)?


          People

          • Assignee:
            savu.andrei Andrei Savu
            Reporter:
            savu.andrei Andrei Savu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development