Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.1.0
    • Component/s: contrib/python
    • Labels:
      None

      Description

      This would make it easier to install the scripts.

      1. HADOOP-6454.patch
        34 kB
        Tom White
      2. HADOOP-6454.patch
        34 kB
        Tom White

        Activity

        Tom White created issue -
        Tom White added a comment -

        Patch for an installation script. As a part of this change the reliance on loading VERSION and hadoop-ec2-init-remote.sh files relative to sys.path[0] has been removed. (When this is committed hadoop-ec2-init-remote.sh should be moved using svn mv.)

        Tom White made changes -
        Field Original Value New Value
        Attachment HADOOP-6454.patch [ 12428385 ]
        Tom White made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12428385/HADOOP-6454.patch
        against trunk revision 892066.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        -1 release audit. The applied patch generated 2 release audit warnings (more than the trunk's current 1 warnings).

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/220/testReport/
        Release audit warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/220/artifact/trunk/patchprocess/releaseAuditDiffWarnings.txt
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/220/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/220/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/220/console

        This message is automatically generated.

        Tom White added a comment -

        Release audit failure was caused by the manifest file, which is actually unnecessary since it doesn't specify anything other than the defaults. This patch removes it.

        Tom White made changes -
        Attachment HADOOP-6454.patch [ 12428397 ]
        Tom White made changes -
        Status Patch Available [ 10002 ] Open [ 1 ]
        Tom White made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12428397/HADOOP-6454.patch
        against trunk revision 892113.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 findbugs. The patch does not introduce any new Findbugs warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed core unit tests.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/222/testReport/
        Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/222/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
        Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/222/artifact/trunk/build/test/checkstyle-errors.html
        Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch-h4.grid.sp2.yahoo.net/222/console

        This message is automatically generated.

        Aaron Kimball added a comment -

        +1, looks good. Can you describe any manual testing you've done of the setup.py script, etc?

        Tom White added a comment -

        I ran 'sudo python setup.py install' then launched and terminated a cluster successfully.

        Tom White added a comment -

        I've just committed this.

        Tom White made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags [Reviewed]
        Fix Version/s 0.22.0 [ 12314296 ]
        Resolution Fixed [ 1 ]
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #124 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk-Commit/124/)
        . Create setup.py for EC2 cloud scripts.

        Hudson added a comment -

        Integrated in Hadoop-Common-trunk #196 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Common-trunk/196/)
        . Create setup.py for EC2 cloud scripts.

        Tom White made changes -
        Fix Version/s 0.21.0 [ 12313563 ]
        Fix Version/s 0.22.0 [ 12314296 ]
        Tom White made changes -
        Project Hadoop Common [ 12310240 ] Whirr [ 12311110 ]
        Key HADOOP-6454 WHIRR-10
        Workflow no-reopen-closed, patch-avail [ 12485067 ] jira [ 12512604 ]
        Hadoop Flags [Reviewed]
        Component/s contrib/cloud [ 12311822 ]
        Fix Version/s 0.21.0 [ 12313563 ]
        Tom White made changes -
        Fix Version/s 0.1.0 [ 12315111 ]
        Component/s contrib/python [ 12313573 ]
        Doug Cutting made changes -
        Workflow jira [ 12512604 ] no-reopen-closed, patch-avail [ 12512766 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Patch Available Patch Available Open Open
        2h 48m 1 Tom White 18/Dec/09 04:23
        Open Open Patch Available Patch Available
        9m 38s 2 Tom White 18/Dec/09 04:23
        Patch Available Patch Available Resolved Resolved
        4d 14h 10m 1 Tom White 22/Dec/09 18:34

          People

          • Assignee:
            Tom White
            Reporter:
            Tom White
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development