Uploaded image for project: 'Wave'
  1. Wave
  2. WAVE-440

Update Robot/Gadget API to work with more up to date OAuth libraries

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Extentions, Robots
    • Labels:

      Description

      Our current Robot/Gadget APIs use outdated OAuth libraries that were removed from maven repositories.
      Specifically the dependency [group: "net.oauth.core", name: "oauth-consumer", version: "20100527"]
      We need to update the relevant code to remove the old dependency, by using some newer OAuth libraries like Scribe OAuth Library.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                yurize Yuri Zelikov
                Reporter:
                yurize Yuri Zelikov
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: