Uploaded image for project: 'Maven Wagon'
  1. Maven Wagon
  2. WAGON-466

wagon-ssh: Better error message when ssh account is locked

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.10
    • Fix Version/s: 2.12
    • Component/s: wagon-ssh
    • Labels:
      None

      Description

      When wagon-ssh encounter none prompt eror ( like account is lock) it throws

      Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
      at org.apache.maven.wagon.providers.ssh.jsch.interactive.UserInfoUIKeyboardInteractiveProxy.promptKeyboardInteractive(UserInfoUIKeyboardInteractiveProxy.java:53)
      at com.jcraft.jsch.UserAuthKeyboardInteractive.start(UserAuthKeyboardInteractive.java:141)
      at com.jcraft.jsch.Session.connect(Session.java:470)
      at com.jcraft.jsch.Session.connect(Session.java:183)
      at org.apache.maven.wagon.providers.ssh.jsch.AbstractJschWagon.openConnectionInternal(AbstractJschWagon.java:254)
      at org.apache.maven.wagon.AbstractWagon.openConnection(AbstractWagon.java:115)
      at org.apache.maven.wagon.AbstractWagon.connect(AbstractWagon.java:215)
      at org.apache.maven.wagon.AbstractWagon.connect(AbstractWagon.java:152)

      This is due to empty array UserInfoUIKeyboardInteractiveProxy

      The solution is not handle the empty promt

        Activity

        hudson Hudson added a comment -

        UNSTABLE: Integrated in Jenkins build maven-wagon #1315 (See https://builds.apache.org/job/maven-wagon/1315/)
        WAGON-466 Better error for locked ssh account (dantran: rev 412c0fbd7fb0107804080bb4b58bb0f249c0768a)

        • (edit) wagon-providers/wagon-ssh/src/main/java/org/apache/maven/wagon/providers/ssh/jsch/interactive/UserInfoUIKeyboardInteractiveProxy.java

          People

          • Assignee:
            dantran Dan Tran
            Reporter:
            dantran Dan Tran
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development