Uploaded image for project: 'Maven Wagon'
  1. Maven Wagon
  2. WAGON-464

Upgrade jsch dependency to 0.1.51 or newer to support ECDSA host key typess

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.10
    • Fix Version/s: 2.12
    • Component/s: wagon-ssh
    • Labels:
      None

      Description

      If public keys in known_hosts file are saved in a ECDSA (ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521) format, Maven will fail with the little helpful message:

      Unable to create a Wagon instance for host foo.bar.lan
      

      Switching on debug mode will tell you this, but not the root cause:

      Caused by: org.apache.maven.wagon.providers.ssh.knownhost.UnknownHostException: The host was not known and was not accepted by the configuration: foo.bar.lan
      12:31:44 	at org.apache.maven.wagon.providers.ssh.jsch.AbstractJschWagon.openConnectionInternal(AbstractJschWagon.java:273)
      12:31:44 	at org.apache.maven.wagon.AbstractWagon.openConnection(AbstractWagon.java:116)
      12:31:44 	at org.apache.maven.wagon.AbstractWagon.connect(AbstractWagon.java:218)
      12:31:44 	at org.apache.maven.wagon.AbstractWagon.connect(AbstractWagon.java:153)
      12:31:44 	... 29 more
      12:31:44 Caused by: com.jcraft.jsch.JSchException: reject HostKey: foo.bar.lan
      12:31:44 	at com.jcraft.jsch.Session.checkHost(Session.java:780)
      12:31:44 	at com.jcraft.jsch.Session.connect(Session.java:342)
      12:31:44 	at com.jcraft.jsch.Session.connect(Session.java:183)
      12:31:44 	at org.apache.maven.wagon.providers.ssh.jsch.AbstractJschWagon.openConnectionInternal(AbstractJschWagon.java:253)
      12:31:44 	... 34 more
      

        Issue Links

          Activity

          hudson Hudson added a comment -

          ABORTED: Integrated in Jenkins build maven-wagon #1313 (See https://builds.apache.org/job/maven-wagon/1313/)
          WAGON-464 Upgrade jcsh to jsch (dantran: rev dc78bcd107a2852a8e8401f188ce4e5e97b8508e)

          • (edit) wagon-providers/wagon-ssh/pom.xml
          hudson Hudson added a comment -

          UNSTABLE: Integrated in Jenkins build maven-wagon #1314 (See https://builds.apache.org/job/maven-wagon/1314/)
          WAGON-464 Upgrade jcsh to jsch 0.1.54 (dantran: rev 7516b1832ad8054c949570a37da6eeef43e9bb87)

          • (edit) wagon-providers/wagon-ssh/pom.xml

            People

            • Assignee:
              dantran Dan Tran
              Reporter:
              cschablin Christof Schablinski
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development