Uploaded image for project: 'Maven Wagon'
  1. Maven Wagon
  2. WAGON-439

Jsch issue in java 1.7 and Kerberos-enabled ssh servers

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9
    • Fix Version/s: 2.12
    • Component/s: wagon-ssh
    • Labels:
      None
    • Environment:
      Java 7 + Kerberos enabled ssh server

      Description

      There is a known issue with JSch running in java 7 and connecting to a server with Kerberos enabled: when trying to connect to that server, it will request the kerberos password to be manually entered even if not used.

      The issue is described in the following Ant bug report:
      https://issues.apache.org/bugzilla/show_bug.cgi?id=53437 or Mule https://www.mulesoft.org/jira/browse/MULE-6864

      Setting "PreferredAuthentications" property to "publickey,password,keyboard-interactive" is the solution preconise by Jsch author: http://sourceforge.net/p/jsch/mailman/message/29359265/

        Issue Links

          Activity

          dantran Dan Tran added a comment -

          fixed at WAGON-467


            People

            • Assignee:
              dantran Dan Tran
              Reporter:
              hboutemy Hervé Boutemy
            • Votes:
              2 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development