Uploaded image for project: 'Velocity Tools'
  1. Velocity Tools
  2. VELTOOLS-71

Adapt Velocity Engine's dependency download scripts to work for our build process.

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.3
    • Fix Version/s: 1.3
    • Component/s: Build
    • Labels:
      None

      Description

      This update to the build process is well-overdue.

        Activity

        Hide
        henning Henning Schmiedehausen added a comment -

        this is mostly concentrated in build/download.xml. If you pick up the current HEAD version, I can also apply the gump tweaks to velocity-tools thus building the tools with gump without needing to download the jars in gump (if the bugger finally gives in and builds again tonight...)

        Show
        henning Henning Schmiedehausen added a comment - this is mostly concentrated in build/download.xml. If you pick up the current HEAD version, I can also apply the gump tweaks to velocity-tools thus building the tools with gump without needing to download the jars in gump (if the bugger finally gives in and builds again tonight...)
        Hide
        nbubna Nathan Bubna added a comment -

        Yeah, i've got things mostly working with the download stuff. I didn't get your last set of gump friendly tweaks. I'll try to incorporate those as well.

        There are still remants of the old process in place for building the examples that i need to update before i check this in. Shouldn't take too long though.

        Once this is done, i'll start trying to update the dependency versions as far as possible.

        Show
        nbubna Nathan Bubna added a comment - Yeah, i've got things mostly working with the download stuff. I didn't get your last set of gump friendly tweaks. I'll try to incorporate those as well. There are still remants of the old process in place for building the examples that i need to update before i check this in. Shouldn't take too long though. Once this is done, i'll start trying to update the dependency versions as far as possible.
        Hide
        nbubna Nathan Bubna added a comment -

        Ok. I believe i have everything updated and working now.

        Note that this no longer supports building VelocityTools with JDK 1.3, though you can still run it on that JVM (with the exception of the BrowserSnifferTool). If someone doesn't like this, please protest and, if you want this to work soon, provide a patch for the build files in order to enable this.

        Show
        nbubna Nathan Bubna added a comment - Ok. I believe i have everything updated and working now. Note that this no longer supports building VelocityTools with JDK 1.3, though you can still run it on that JVM (with the exception of the BrowserSnifferTool). If someone doesn't like this, please protest and, if you want this to work soon, provide a patch for the build files in order to enable this.
        Hide
        wglass Will Glass-Husain added a comment -

        requiring 1.4 to build seems fine to me.

        Is this requirement documented? See the new section on dependencies in the Velocity docs: xdocs/build.xml

        (haven't deployed to the main site since it is 1.5 specific).

        Show
        wglass Will Glass-Husain added a comment - requiring 1.4 to build seems fine to me. Is this requirement documented? See the new section on dependencies in the Velocity docs: xdocs/build.xml (haven't deployed to the main site since it is 1.5 specific).
        Hide
        nbubna Nathan Bubna added a comment -

        It's in the changelog now, but i don't think it matters since the building with jdk 1.3 feature doesn't/didn't work in version 1.2 and no one complained. i don't think anyone in our community is building or needs to build with 1.3 these days, and i'm certainly not interested in encouraging it at this point.

        Show
        nbubna Nathan Bubna added a comment - It's in the changelog now, but i don't think it matters since the building with jdk 1.3 feature doesn't/didn't work in version 1.2 and no one complained. i don't think anyone in our community is building or needs to build with 1.3 these days, and i'm certainly not interested in encouraging it at this point.

          People

          • Assignee:
            nbubna Nathan Bubna
            Reporter:
            nbubna Nathan Bubna
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development