Uploaded image for project: 'Velocity Tools'
  1. Velocity Tools
  2. VELTOOLS-172

Remove dependency on Apache Commons Validator



    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.0.x, 2.x
    • Fix Version/s: 3.0
    • Component/s: VelocityStruts
    • Labels:
    • Flags:


      Please upgrade Apache Commons Validator to a supported, secure version. At this time, that appears to mean upgrading to 1.6


      There is at least one publicly known high severity vulnerability (CVE-2014-0114), allowing remote code execution, affecting all versions from 1.3.1 through 1.4.1.

      A cursory review shows that there do not appear to be publicly known vulnerabilities in 1.5 and above.


      Apache Commons Validator 1.3.x has not had a release since 2006, but VelocityTools depends upon Validator 1.3. I was unable to determine which branches Validator considers to be supported, so am suggesting upgrade to 1.6. Given the release history of one major release followed by one minor release, then moving immediately to the next major release, this seems like a reasonable starting target.

      When vulnerabilities are discovered in unsupported software, the industry standard response is "you need to patch to a supported version." If you get too far behind in patch levels, then it may be very difficult to upgrade due to broken backwards compatibility.

      Furthermore, when vulnerabilities are discovered in supported software, there is no industry standard for determining if it affects unsupported versions. It's entirely possible that there are known vulnerabilities that affect the apparantly-unsupported Apache Commons Validator 1.3 required by Velocity, and nobody will know until they're breached. On the other hand, when there's a supported major version, it's a de-facto industry standard to announce all supported versions that are affected. This means that staying on a supported version increases the chances of seeing vulnerability announcements for vulns that affect Velocity. It also means that staying on an unsupported version is considered equivalent to staying on a known vulnerable version.


          Issue Links



              • Assignee:
                tsohlacol Aaron Katz
              • Votes:
                0 Vote for this issue
                5 Start watching this issue


                • Created: