Velocity
  1. Velocity
  2. VELOCITY-693

resourceExists method in FileResourceLoader returns always false if the template is not in the first directory

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.6.1
    • Fix Version/s: 1.6.2, 1.7, 2.x
    • Component/s: Engine
    • Labels:
      None

      Description

      In case of a multi path resource loader the resourceExists method doesn't work if the template is not in the first directory. It returns alway false, although the resource exists.

        Activity

        Johann Weber created issue -
        Hide
        Nathan Bubna added a comment -

        This is a problem with the new resourceExists method. Fix is obvious. Will patch shortly...

        Show
        Nathan Bubna added a comment - This is a problem with the new resourceExists method. Fix is obvious. Will patch shortly...
        Hide
        Nathan Bubna added a comment -

        Ok, fixed in all branches.

        Show
        Nathan Bubna added a comment - Ok, fixed in all branches.
        Nathan Bubna made changes -
        Field Original Value New Value
        Resolution Fixed [ 1 ]
        Fix Version/s 1.6.2 [ 12313574 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.7 [ 12313453 ]
        Fix Version/s 2.0 [ 12310291 ]
        Mark Thomas made changes -
        Workflow jira [ 12452455 ] Default workflow, editable Closed status [ 12551616 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12551616 ] jira [ 12552499 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Johann Weber
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development