Velocity
  1. Velocity
  2. VELOCITY-690

Do not require block directive to have parenthesis

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.x
    • Fix Version/s: None
    • Component/s: Engine
    • Labels:
      None

      Description

      Block directives are currently required by the parser to contain parenthesis, which includes block macros. So

      #@foo
      #end

      is not allowed, and neither are custom block directives. Removing this requirement makes the syntax consistent with line directives.

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Unassigned
            Reporter:
            Byron Foster
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development