Velocity
  1. Velocity
  2. VELOCITY-667

Regression: Specifying #macro without parenthesis no longer throws VelocityException

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.1
    • Fix Version/s: 1.6.2
    • Component/s: Engine
    • Labels:
      None

      Description

      With version 1.5, VelocityEngine.mergeTemplate() would throw VelocityException if I specified a grammar error in the template. This is what I was using my unit test to show that parsing would fail:

      #macro #macro

      Now in 1.6.1, it renders an empty string. Method:
      velocityEngine.mergeTemplate(templateLocation, velocityContext, writer);

        Activity

        Byron Foster added a comment -

        If this fix looks good, and we want to move it to 1.6.2 we'll need to move the Parser.jjt change to the 1.6.2 branch, and re-run javacc in that branch

        Paul Benedict added a comment -

        I am updating the ticket title according to the fix.

        Byron Foster added a comment -

        Looks like this will fly, changes have been merged over for inclusion into the 1.6.2 release


          People

          • Assignee:
            Unassigned
            Reporter:
            Paul Benedict
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development