Velocity
  1. Velocity
  2. VELOCITY-557

Parsing error when defining a Map where the last entry is a reference

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.5
    • Fix Version/s: 1.6
    • Component/s: Engine
    • Labels:
      None
    • Environment:
      Windows

      Description

      When defining a map like this:

      #set($map =

      {"param1":"test", "param2":$test}

      )

      I get a parsing exception:
      Encountered "}" at line .....
      Was expecting one of:
      "," ...
      "}" ...

      However the problem happens only, if the last argument is a reference - as opposed to a hard coded value - so if i define the map like this:
      #set($map =

      {"param2":$test, "param1":"test"}

      )
      it works fine.

        Activity

        Will Glass-Husain added a comment -

        duplicate of VELOCITY-538. Fixed in svn head.


          People

          • Assignee:
            Unassigned
            Reporter:
            Guido Deinhammer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development