Velocity
  1. Velocity
  2. VELOCITY-223

VMs that use a large number of directives and macros use excessive amounts of memory - over 4-6MB RAM per form

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.1
    • Fix Version/s: 1.6
    • Component/s: Engine
    • Labels:
      None
    • Environment:
      Operating System: All
      Platform: All

      Description

      Our application FinanceCenter is based on Velocity as the template engine. We
      have a library of about 200 macros and about 400 VM files. Because the
      velocity parser copies the macro body into the VM during parsing, macros that
      are frequently used (even though identical and using local contexts) use up
      large amounts of memory. On our Linux server (running Redhat 7.2 with Sun JDK
      1.4.1_04) we can easily use up over 1GB of RAM simply by opening up many forms
      (about 150) - the server starts out using 60MB after startup. This memory
      times out after 5 minutes and is returned which tells me that it is screen
      memory. Our problem is that the NT JVM and Linux JVM (32 bit) are currently
      limited to about 1.6 - 2.0 GB of ram for heap space. Thus, using a fair number
      of forms in the application leaves little space for user session data.

      We have implemented a caching mechanism for compiled templates and integrated
      it into Velocity so that cached objects are timed out of the cache but the
      server is still using large amounts of memory. We finally had to rewrite many
      of our macros into Java so that memory usage would be reduced (note that these
      macros were doing complex screen formatting not business logic). Doing this
      has reduced our memory by about 30%. This is currently our biggest issue with
      Velocity and is causing us to review our decision to stay with Velocity going
      forward. This is because we will likely end up with close to 1,000 forms by
      the end of next year and need to know that Velocity can deal with this. Is
      there any work underway to share compiled macro AST's? This would greatly
      reduce the amount of memory used. I have reviewed the parser code that is
      doing this but it seems that this is an embedded part of the design and not
      easily changed.

      1. VelocityMemory.JPG
        63 kB
        Ryan Smith
      2. VelocityCharStream.java
        13 kB
        Lei Gu
      3. StringImagePool.java
        0.5 kB
        Lei Gu
      4. AllVelocityMemoryByClass.html
        78 kB
        Ryan Smith
      5. 223-patch.txt
        2 kB
        Lei Gu

        Activity

        Christian Nichols created issue -
        Jeff Turner made changes -
        Field Original Value New Value
        issue.field.bugzillaimportkey 24375 12315093
        Henning Schmiedehausen made changes -
        Bugzilla Id 24375
        Assignee Velocity-Dev List [ velocity-dev@jakarta.apache.org ]
        Fix Version/s 1.6 [ 12310290 ]
        Component/s Engine [ 12311337 ]
        Component/s Source [ 12310214 ]
        Ryan Smith added a comment -

        This is a picture of the YourKit memory for all of the owned objects for one of our library files.

        Ryan Smith made changes -
        Attachment VelocityMemory.JPG [ 12352040 ]
        Ryan Smith added a comment -

        We have a web site where we use velocity to generate our HTML pages.
        Recently I was asked to help troubleshoot some performance issues and
        the root cause of our problem was that the velocity cache had grown to
        well over 1GB in size causing the JVM to continuously GC to try to free up
        memory.

        I used the YourKit memory profiler and found the following information
        about the individual velocity cache entries (see attached picture):

        Name Cache Size File Size
        ---------------------------------------------------
        VM_framework_library.vm 9,596,472 130,500
        VM_buttons_library.vm 1,195,680 39,113
        VM_layout_library.vm 1,683,256 54,371
        admin/AdminHome.vm 32,505,168 979
        poNewGrid.vm 14,399,648 753
        poTemplateGrid.vm 14,369,000 774
        po/details.vm 11,140,952 8,368
        sub.vm 10,115,096 24,576

        Ryan Smith added a comment -

        Attaching HTML page (no pics sorry) that shows the number of objects and their owned object size using YourKit's memory profiler.

        Ryan Smith made changes -
        Attachment AllVelocityMemoryByClass.html [ 12353251 ]
        Lei Gu added a comment -

        Patch fixes for issue 223

        Issue number 223, Velocity Engine uses excessive amount of memory when a large number of directives and macros are used.

        When a macro or directive is used, they are parsed at run time and the same macro will be parsed every time it is invoked from another macro. This results in an explosion of the duplicated string images. We introduce a string image pool. Before a string image is returned from VelocityCharStream GetImage method, we simply checks against the string image pool. If the string image exists in the pool, we will return the image from the pool. Otherwise we simply return the image itself. We observe a 30% memory footprint reduction after this.

        Lei Gu made changes -
        Attachment 223-patch.txt [ 12354749 ]
        Lei Gu added a comment -

        Issue number 223, Velocity Engine uses excessive amount of memory when a large number of directives and macros are used.

        When a macro or directive is used, they are parsed at run time and the same macro will be parsed every time it is invoked from another macro. This results in an explosion of the duplicated string images. We introduce a string image pool. Before a string image is returned from VelocityCharStream GetImage method, we simply checks against the string image pool. If the string image exists in the pool, we will return the image from the pool. Otherwise we simply return the image itself. We observe a 30% memory footprint reduction after this.

        Lei Gu made changes -
        Attachment VelocityCharStream.java [ 12354751 ]
        Attachment StringImagePool.java [ 12354750 ]
        Will Glass-Husain added a comment -

        Nice catch.

        One quick question. Have you tried the String.intern() method instead? I wonder if this has similar performance. If so, I think that'd be preferred – why reinvent the wheel?

        Also note that our compatibility standard is JDK 1.3.1 – no generics, please.

        Nathan Bubna added a comment -

        Those are great numbers! I'm excited to have a such potential boost to our velocimacro memory performance! Still, i have two questions...

        a) Why does this work? Clearly, i'm ignorant of the inner workings of the String class! I'd never have thought to try something like this. This is mysterious to me; i'd love to learn why this works.

        b) What good is the synchronization around the call to stringImagePool.put()? If we're concerned about stringImages stomping on one another, shouldn't we just use Hashtable or synchronize the whole method?

        Alexey Panchenko added a comment -

        Synchronization

        "stringImagePool.get(image)" should be inside synchronized block too.

        Memory Usage

        The memory held by "private static Map<String, String> stringImagePool" will be never released. The same applies to String.intern().

        Christopher Schultz added a comment -

        Since Velocity already depends on commons-collections, why not use a ReferenceMap with non-hard references within StringImagePool? This way, you essentially get timeout behavior where old, unused keys (and values) will be GC'd.

        Will Glass-Husain added a comment -

        that makes sense to me. the memory issue is a good explanation of why it'd be useful to keep our own pool rather than use String intern()

        Christopher Schultz added a comment -

        After looking at the (patched, above) code to VelocityCharStream.java, I'm not sure where all the memory savings is coming from.

        I'm guessing that the patched version just includes a trip through the StringImagePool to 'canonicalize' the strings. The only overhead that is being saved is the overhead of additional String objects (keep reading).

        The bulk of a String object is usually its character array representing the contents of the String. Since Strings are immutable, the Java folks figured they'd use that to their advantage and share character arrays between String objects created from each other. That means that if you start out with a big String and create lots of little substrings from that first once, you get lots of objects, but only a single copy of the actual content (one big char array and lots of indexes into it).

        Has anyone actually observed any significant memory savings from this?

        I seem to recall that the minimum byte overhead for any object is about 8 bytes (that includes the superclass pointer, etc.). The String class contains 3 4-byte ints and a reference to the char array (# of bytes depend on the architecture, VM, etc.). Assuming a vanilla 32-bit VM with no tricks, we're talking about adding 16 bytes to the existing 8 byte overhead for a grant total of 24 bytes per String object (remember, the character array should be shared).

        Perhaps there are so many of these little objects lying around that simply removing all the extra copies of "else" really helps.

        Are there other places where tons of memory gets used? The memory map I see attached to this bug suggests that the Template objects are responsible for a lot of memory. I imagine that an AST is built from the original text of the template. Do we continue to keep the text of the template in memory after parsing? It seems to me that the template texts themselves could add up if they're being kept around in memory.

        Anyone care to comment?

        Nathan Bubna added a comment -

        Lei has tested and confirmed memory savings, and i see no reason to doubt that unless someone gets other results. His explanation of why it saved memory also makes sense. He sent it to the mailing list in response to my comments above, so i'll repost here:

        On April 2, Lei Gu said:

        Hi Nathan,
        a) In the original code, a new copy of string image is constructed and
        returned as part of the token, which is part of a node. When we cache
        templates, these nodes stay in memory forever or until the template itself
        is booted from the cache. We improved this by checking against the string
        image pool. If the image already exists in the pool, the reference for the
        image is used instead of the newly created string. The newly created string
        will be garbage collected.

        b) This image pool is being called constantly and that's why we don't want
        to synchronized on the get call. It is okay to have one thread overwrites
        the other's string image and the overwritten images won't be lost if there
        could be existing references to them.
        Thanks.
        – Lei

        Nathan Bubna added a comment -

        Oh, and to finish out my conversation with Lei, he acknowledged that the synchronization of put() is useless and can be removed:

        On 4/2/07, Lei Gu <Lei.Gu@authoria.com> wrote:
        >
        > You got me there. I thought put will be called a lot less than get but you
        > are right,
        > we should be able to remove it as well.
        > – Lei
        >
        >
        > Nathan Bubna wrote:
        > >
        > > On 4/2/07, Lei Gu <Lei.Gu@authoria.com> wrote:
        > >>
        > >> Hi Nathan,
        > >> a) In the original code, a new copy of string image is constructed and
        > >> returned as part of the token, which is part of a node. When we cache
        > >> templates, these nodes stay in memory forever or until the template
        > >> itself
        > >> is booted from the cache. We improved this by checking against the string
        > >> image pool. If the image already exists in the pool, the reference for
        > >> the
        > >> image is used instead of the newly created string. The newly created
        > >> string
        > >> will be garbage collected.
        > >
        > > cool. thanks for the explanation!
        > >
        > >> b) This image pool is being called constantly and that's why we don't
        > >> want
        > >> to synchronized on the get call. It is okay to have one thread overwrites
        > >> the other's string image and the overwritten images won't be lost if
        > >> there
        > >> could be existing references to them.
        > >
        > > i thought so. so why synchronize put() at all? doesn't it only delay
        > > the overwriting and slow things down needlessly?
        > >
        > >> Thanks.
        > >> – Lei
        > >>

        Nathan Bubna added a comment -

        So, all told. I think if we drop the static Map for a ReferenceMap (as Christopher suggested), drop the synchronization (as per the discussion between Lei and me), and retest to confirm the memory savings then this is ready to go into the codebase.

        Alexey Panchenko added a comment -

        The reason to high memory usage is that each macro invocation compiles it's own AST.

        I have made the simple test:

        VM_global_library.vm contains
        #macro(test)
        ~10kb of text here
        #end

        test10.vm contains 10 lines #test()
        test100.vm contains 100 lines #test()

        The code
        VelocityEngine engine = new VelocityEngine();
        engine.init();
        Template t10 = engine.getTemplate("test10.vm");
        t10.merge(new VelocityContext(), new StringWriter());
        Template t100 = engine.getTemplate("test100.vm");
        t100.merge(new VelocityContext(), new StringWriter());

        Looking in the profiler - there are two instances of Template with sizes 450kb and 4.5Mb

        Currently the macros works as follows:
        When macro is declared is text body is constructed back from AST.
        When macro is called - each macro invocation compiles his text body to AST again.

        Why is it implemented that way?

        Lei Gu added a comment -

        Hi Chris or Will,
        Please remove synchronized key word from ASTSetDirective.java's render method. It wasn't really necessary.
        Thanks.
        – Lei

        Will Glass-Husain added a comment - - edited

        Hi,

        Thanks for all contributions on this old but important issue.

        I've dug into this a bit. Alexey's succinct analysis is correct (also described by Lei). Fundamentally, the issue is that every rendering of a template with macros creates a new String object containing the body of the macro.

        Alexey asks "Why is it implemented this way"? From a common-sense perpective, it seems like it would make more sense to parse the macro body, then share a common parse tree among all templates which use the macro.

        There are two reasons this is difficult
        (1) Macros are dynamically included at runtime, not parse-time. Different macros (with the same name) may be included with #parse

        (2) Templates are cached. I haven't investigated this in too much depth, but it seems likely to me that if the code shares a parse tree among different templates (or different templates included with #parse) it may run into caching/update issues.

        This is a long-winded way of noting that I think the simplest solution is Lei's patch. Originally I thought this was a litle kludgy, but now I like the way it drastically saves memory without imposing the effort of redoing the existing macro mechanism. I'm setting up some "before" and "after" tests to verify the performance claims, but I just wanted to note I think this is the right way to go.

        Will Glass-Husain added a comment -

        Dear Lei,

        I cannot apply your patch to the Velocity code base as you did not check the box to grant the license to the ASF.

        Can you please respond stating

        "I grant license to ASF for this patch for inclusion in ASF works (as per the Apache License §5) "

        Thanks, WILL

        Will Glass-Husain added a comment -

        Ok, never mind my previous two comments. After doing some testing with YourKit, it's apparent that memory usage for templates is drastically lower in the current 1.6-dev version (svn head) than in version 1.5. And specifically, repeated macro calls in templates do not boost memory usage.

        It turns out that the major refactoring to the macro system last summer by Supun took care of this issue. Macros are now stored in a common macro library instead of a template by template basis. They are still stored as a String (this is what confused me when I was reading the code). But they are not duplicated for each template that is loaded.

        Alexey's example generates two template objects that are just a few bytes in size. The macros are stored in the VelocimacroManager, which is basically the size of the macro body plus a little overhead.

        Resolving this old issue without applying Lei's patch. (Thanks very much to all for the analysis and very reasonable solution). If anyone has comments or still sees problems, reopen this bug or discuss on the dev list.

        Will Glass-Husain made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Mark Thomas made changes -
        Workflow jira [ 12325098 ] Default workflow, editable Closed status [ 12551874 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12551874 ] jira [ 12552303 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Christian Nichols
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development