Uploaded image for project: 'UIMA'
  1. UIMA
  2. UIMA-6350

japicmp post processing script fails with Java 16 (parent pom)

    XMLWordPrintableJSON

Details

    Description

      When building the UIMA Java SDK with a Java 16 JDK, we get the following error:

      [ERROR] Failed to execute goal com.github.siom79.japicmp:japicmp-maven-plugin:0.14.4:cmp (default) on project uimaj-core: Execution of post-analysis script failed: javax.script.ScriptException: groovy.lang.MissingMethodException: No signature of method: java.lang.String.endsWith() is applicable for argument types: (java.lang.String) values: [_Type] -> [Help 1]

      Works with Java 15.

      The fix is apparently to force japicmp to use a new Groovy version:

      <plugin>
              <groupId>com.github.siom79.japicmp</groupId>
              <artifactId>japicmp-maven-plugin</artifactId>
              <version>0.15.3</version>
              <dependencies>
                <dependency>
                  <groupId>org.codehaus.groovy</groupId>
                  <artifactId>groovy-jsr223</artifactId>
                  <version>2.5.14</version>
                </dependency>
              </dependencies>
            </plugin>
      

      Attachments

        Issue Links

          Activity

            People

              rec Richard Eckart de Castilho
              rec Richard Eckart de Castilho
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated: