Uploaded image for project: 'UIMA'
  1. UIMA
  2. UIMA-4119

jcasgen-maven-plugin generates no files on Windows

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.0SDK
    • Fix Version/s: 2.7.0SDK
    • Component/s: Tools
    • Labels:
      None

      Description

      jcasgen-maven-plugin generates a temporary type system file importing all type system files for which JCas classes should be generated. On Windows, this file contains invalid imports, e.g.:

      <?xml version="1.0" encoding="UTF-8"?>
      <typeSystemDescription xmlns="http://uima.apache.org/resourceSpecifier">
          <imports>
              <import location="file:/C:/de.tudarmstadt.ukp.dkpro.core-asl/de.tudarmstadt.ukp.dkpro.core.api.lexmorph-asl/src/main/resources/desc/type/Morpheme.xml"/>
              <import location="file:/C:/de.tudarmstadt.ukp.dkpro.core-asl/de.tudarmstadt.ukp.dkpro.core.api.lexmorph-asl/src/main/resources/desc/type/POS.xml"/>
          </imports>
      </typeSystemDescription>
      

      The paths in this file appear to be absolute paths starting with C:\, but actually they are relative to the Eclipse workspace root.

        Activity

        rec Richard Eckart de Castilho added a comment -

        Changed component to tools because the fix is in the Jg class in the tools module, not in the jcasgen-maven-plugin. It only provided one of the contexts where this issue surfaced. Another would have been using the limit feature on the command line.

        rec Richard Eckart de Castilho added a comment -

        Checked in OS X and Windows. Looks ok.

        rec Richard Eckart de Castilho added a comment - - edited

        On windows, the default path representation and the URI path representation differ: "/C:/..." vs. "C:\...". For this reason, Jg.isOutOfScope() fails to detect that types are within scope on Windows and generates nothing.

        That doesn't explain why the user reporting this problem initially had strange imports in the temporary type system descriptor, but it was the reason why type generation failed when I tried to reproduce this. Let's see if that also fixes the issue for the user.


          People

          • Assignee:
            rec Richard Eckart de Castilho
            Reporter:
            rec Richard Eckart de Castilho
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development