UIMA
  1. UIMA
  2. UIMA-2114

Endless dialogs when Capabilities Types/Features misclicked

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.2, 2.3.1SDK
    • Fix Version/s: 2.4.0SDK
    • Component/s: Eclipse plugins
    • Labels:
    • Environment:

      Mac OSX 10.6.6, JDK 1.6, Eclipse 3.5.2

      Description

      Can reproduce using the UIMA tutorial.

      1) Open RoomNumberAnnotator.xml
      2) Go to Capabilities tab.
      3) Double click RoomNumber type to edit.
      4) In the Edit Types to a Capability Set, click anywhere in the grid outside the Input / Output cell columns (e.g., click RoomNumber in TypeName).
      5) A dialog appears telling you to click in the right columns.
      6) Try clicking OK in the dialog and another appears.
      7) Repeat 5-7 ad infinitum.

      Have to quit Eclipse at this point to get out of the loop. Same thing happens in the Add/Edit Features dialog too.

        Activity

        Marshall Schor added a comment -

        Works OK on Eclipse 3.6.1 / Windows XP. On my Macbook Pro (3.6.0 verson of Eclipse. using the 32 bit version I think of the graphics libs (I forget exactly which I loaded), Java 1.6.0 _ 24) it misbehaves but not quite like above.

        If I misclick (click on the type number (left column)), it does one of the following:

        1) - puts up the dialog telling you to click in the right columns, when you press OK, it puts up 2 more of those boxes, one of which has the OK button highlighted, when you click on that OK, puts up 1 more of those boxes, and when you click OK, it goes away...

        2) - puts up the dialog, but doesn't reliably put it in "front" of the Eclipse screen, so you can't click on it.

        For (2) - a workaround I found was to close the macbook, making it go to sleep, then open it, and when I log in, it then shows the windows in the right order.

        This looks like it might be some kind of timing / race condition issue for Eclipse SWT modal dialogs.

        One thing to try is to see if the "Sheets" style works better on a mac - see http://www.eclipse-tips.com/how-to-guides/27-making-good-eclipse-rcp-apps-for-mac (it may be a while before I get time to try this, myself...)

        Marshall Schor added a comment -

        This is only reproducible on a MAC. Fails with Eclipse 3.6.0, 3.7.0

        Marshall Schor added a comment -

        Mostly works now on Macbook - may require multiple clicking of "ok" button (for reasons unknown), but at least you can now do that, instead of being hung. On windows, works fine.


          People

          • Assignee:
            Marshall Schor
            Reporter:
            Peter Parente
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development