Uploaded image for project: 'UIMA'
  1. UIMA
  2. UIMA-1937

UIMA AS JMX Monitor throws javax.management.AttributeNotFoundException: No such attribute: AvailableInstances

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3.1AS
    • Component/s: Async Scaleout
    • Labels:
      None

      Description

      The JMX Monitor throws javax.management.AttributeNotFoundException: No such attribute: AvailableInstances exception when it tries to access CM CasPool MBean properties. Looks like RMI proxy is not valid when the look up is done

        Activity

        cwiklik Jerry Cwiklik added a comment -

        The cause of the exception was an invalid proxy to a Cas Multiplier CasPoolMBean. A proxy was instantiated during initialization of the JMX Monitor but it was not properly initialized due to an invalid name used to lookup the MBean. The names of the colocated CM Cas Pool MBeans were changed to support multple CM in the same JVM. The names now contain a unique string to identify each instance.


          People

          • Assignee:
            cwiklik Jerry Cwiklik
            Reporter:
            cwiklik Jerry Cwiklik
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development