Uploaded image for project: 'Traffic Server'
  1. Traffic Server
  2. TS-4330

Real or statistical differences in response time between 5.3 and 6.1

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 7.0.0
    • Component/s: Performance
    • Labels:
      None

      Description

      We are evaluating 6.1 in our production caching environment and verifying it against a 5.3.x box in the same pod.

      Our performance reporter (ysar) shows that the response time for 6.1 is higher than it is on the 5.3 box. The difference is in the range of 10ms.

      We also noticed that the error statistics difference. In 6.1 the reported client aborts are higher. Also the number of connection failures is low and the number of "other" errors is higher. In 5.3, the number of connection failures is higher and the number of "other" errors is low.

      Finally, I set the slow log on both machines. On the 6.1 machine, I see every second or two an entry with ua_begin set to 0, all other fields set to -1 except for sm_finish which is 120 seconds. I do not see these slow logs on the 5.3 machine. It is as if the TCP deferred accept path is not being used on the 6.1 build.

      We are continuing to investigate, but wanted to share in case others have seem similar issues.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              shinrich Susan Hinrichs
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: