MyFaces Trinidad
  1. MyFaces Trinidad
  2. TRINIDAD-2291

Binary incompatibility with RequestContext from 2.0.1

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.0-core
    • Fix Version/s: 2.1.0-core
    • Component/s: Infrastructure
    • Labels:
      None

      Description

      The commit for TRINIDAD-2258 (txn 1330065) introduced a binary compatibility issue from 2.0.1. Essentially 2 method were added to the RequestContext for chunked file uploading. In order to catch new API's, I've been updating the clirr runner tests to ensure binary compatibility with 2.0.1.

      For this class to be strictly binary compatible, you need to provide a default implementation for these new methods in the abstract class. I understand that there are generally not many implementations of this class, but some mock object also needed to be changed because of this incompatibility and given the nature of these methods, I do not thing a default implementation would be too difficult. Can you please fix this and submit a patch so the clirr runner tests may be updated.

      1. TRINIDAD-2291.patch
        0.8 kB
        Kentaro Kinebuchi

        Issue Links

          Activity

          Scott O'Bryan created issue -
          Scott O'Bryan made changes -
          Field Original Value New Value
          Link This issue is broken by TRINIDAD-2258 [ TRINIDAD-2258 ]
          Scott O'Bryan added a comment -

          This regression was caused by TRINIDAD-2285

          Scott O'Bryan made changes -
          Link This issue blocks TRINIDAD-2172 [ TRINIDAD-2172 ]
          Scott O'Bryan made changes -
          Link This issue blocks TRINIDAD-2172 [ TRINIDAD-2172 ]
          Scott O'Bryan made changes -
          Link This issue blocks TRINIDAD-2292 [ TRINIDAD-2292 ]
          Kentaro Kinebuchi added a comment -

          Attached a patch which adds default implementations to the abstract class.

          Kentaro Kinebuchi made changes -
          Attachment TRINIDAD-2291.patch [ 12537229 ]
          Kentaro Kinebuchi made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Scott O'Bryan made changes -
          Status Patch Available [ 10002 ] In Progress [ 3 ]
          Scott O'Bryan added a comment -

          Checked into trunk (1363499)

          Scott O'Bryan made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Fix Version/s 2.1.0-core [ 12320549 ]
          Resolution Fixed [ 1 ]
          Scott O'Bryan made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Patch Available Patch Available
          2h 44m 1 Kentaro Kinebuchi 19/Jul/12 20:07
          Patch Available Patch Available In Progress In Progress
          27m 58s 1 Scott O'Bryan 19/Jul/12 20:35
          In Progress In Progress Resolved Resolved
          43s 1 Scott O'Bryan 19/Jul/12 20:35
          Resolved Resolved Closed Closed
          15s 1 Scott O'Bryan 19/Jul/12 20:36

            People

            • Assignee:
              Scott O'Bryan
              Reporter:
              Scott O'Bryan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development