Uploaded image for project: 'Torque'
  1. Torque
  2. TORQUE-228

Imports not generated correctly if classes are generated into different package

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.0-beta1
    • Fix Version/s: 4.0
    • Component/s: Templates
    • Labels:
      None

      Description

      If the generation options torque.om.package.$

      {...}

      PackageSuffix are all set to different values, some generated files miss imports to other files.
      It should be possible to set all these options to different values and still have compiling code.

        Activity

        tfischer Thomas Fox added a comment -

        The test project should be reorganized accordingly to test the behavior.
        The problem is that the files using the "protected" attribute do not compile anymore, there the package should be overridden in the table definition.


          People

          • Assignee:
            tfischer Thomas Fox
            Reporter:
            tfischer Thomas Fox
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development