Currently, the word "Database" is quite overloaded in Torque. It means the name of the database (as in Torque.getDefaultDB()) as well as the information about a particular database (as in the class Database).
To add to the confusion, there is also the class name org.apache.torque.adapter.DB which holds the interface for a database adapter for the runtime.
That class name should be changed to"Adapter".
Also, all methods to retrieve an adapter but are named "DB" (as in Torque.getDB()) should be deprecated; and new methods which are named "Adapter" (as Torque.getAdapter()) should be added.