Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0-beta1
    • Component/s: None
    • Labels:
      None

      Description

      A lot of database adapters are for very outdated databases which are not supported any more by the torque templates. Adapters and documentation should be cleaned.

        Activity

        Thomas Fox made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Thomas Fox made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 4.0 [ 12312102 ]
        Resolution Fixed [ 1 ]
        Hide
        Thomas Fox added a comment -

        Did not find any other adapters than the six mentioned above in the following places:

        • templates package org.apache.torque.templates.platform
        • templates resources package org.apache.torque.templates.sql
        • runtime package org.apache.torque.adapter
        • site file src/site/xdoc/version-specific/supported-databases.xml
        • site directory src/site/xdoc/version-specific/database-howtos
          so I consider the cleanup done.
        Show
        Thomas Fox added a comment - Did not find any other adapters than the six mentioned above in the following places: templates package org.apache.torque.templates.platform templates resources package org.apache.torque.templates.sql runtime package org.apache.torque.adapter site file src/site/xdoc/version-specific/supported-databases.xml site directory src/site/xdoc/version-specific/database-howtos so I consider the cleanup done.
        Hide
        Thomas Fox added a comment -

        The following adapters will remain: mysql, postgresql, derby, oracle, mssql, hsqldb
        hsqldb will support version 2x, not sure whether it will still support 1.x.

        Show
        Thomas Fox added a comment - The following adapters will remain: mysql, postgresql, derby, oracle, mssql, hsqldb hsqldb will support version 2x, not sure whether it will still support 1.x.
        Hide
        Ludwig Magnusson added a comment -

        Which adapters are considered to be outdated?

        I also have a question about the Hpersonic Adapter. Is it supposed to work for hsql 2.0?
        If not, is it more likely to be removed or updated?

        Show
        Ludwig Magnusson added a comment - Which adapters are considered to be outdated? I also have a question about the Hpersonic Adapter. Is it supposed to work for hsql 2.0? If not, is it more likely to be removed or updated?
        Thomas Fox made changes -
        Field Original Value New Value
        Assignee Thomas Fox [ tfischer ]
        Thomas Fox created issue -

          People

          • Assignee:
            Thomas Fox
            Reporter:
            Thomas Fox
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development