Uploaded image for project: 'TomEE'
  1. TomEE
  2. TOMEE-27

UnknownModuleTypeException thrown when no-web.xml webapp deployed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0-beta-1
    • Fix Version/s: 1.0.0
    • Component/s: None
    • Labels:
      None

      Description

      When a no-web.xml webapp is deployed onto TomEE, the following exception's thrown.

      Oct 8, 2011 12:55:28 PM org.apache.catalina.startup.HostConfig deployWAR
      INFO: Deploying web application archive TomEnvEntryWeb.war
      TomcatWebAppBuilder.start
      Oct 8, 2011 12:55:28 PM org.apache.catalina.core.ContainerBase addChildInternal
      SEVERE: ContainerBase.addChild: start:
      org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/TomEnvEntryWeb]]
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:152)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:812)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:787)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:607)
      at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:932)
      at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:529)
      at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1384)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.tomcat.util.modeler.BaseModelMBean.invoke(BaseModelMBean.java:301)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:836)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:761)
      at org.apache.catalina.manager.ManagerServlet.check(ManagerServlet.java:1436)
      at org.apache.catalina.manager.HTMLManagerServlet.upload(HTMLManagerServlet.java:334)
      at org.apache.catalina.manager.HTMLManagerServlet.doPost(HTMLManagerServlet.java:211)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:641)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:304)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.filters.CsrfPreventionFilter.doFilter(CsrfPreventionFilter.java:187)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:108)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:224)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:185)
      at org.apache.openejb.tomcat.catalina.OpenEJBValve.invoke(OpenEJBValve.java:44)
      at org.apache.openejb.tomcat.catalina.OpenEJBValve.invoke(OpenEJBValve.java:44)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:581)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:151)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:100)
      at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:929)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:405)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:269)
      at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:515)
      at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:300)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.RuntimeException: org.apache.openejb.config.UnknownModuleTypeException: Unable to determine module type for jar: file:/Users/jacek/oss/openejb/assembly/openejb-tomcat/openejb-tomcat-bundle/tomee7/target/apache-tomee-webprofile-1.0.0-beta-2-SNAPSHOT/webapps/TomEnvEntryWeb/: Unknown module type: url=file:/Users/jacek/oss/openejb/assembly/openejb-tomcat/openejb-tomcat-bundle/tomee7/target/apache-tomee-webprofile-1.0.0-beta-2-SNAPSHOT/webapps/TomEnvEntryWeb/
      at org.apache.openejb.tomcat.catalina.TomcatWebAppBuilder.loadApplication(TomcatWebAppBuilder.java:892)
      at org.apache.openejb.tomcat.catalina.TomcatWebAppBuilder.startInternal(TomcatWebAppBuilder.java:433)
      at org.apache.openejb.tomcat.catalina.TomcatWebAppBuilder.configureStart(TomcatWebAppBuilder.java:394)
      at org.apache.openejb.tomcat.catalina.GlobalListenerSupport.lifecycleEvent(GlobalListenerSupport.java:117)
      at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
      at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5103)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:148)
      ... 42 more
      Caused by: org.apache.openejb.config.UnknownModuleTypeException: Unable to determine module type for jar: file:/Users/jacek/oss/openejb/assembly/openejb-tomcat/openejb-tomcat-bundle/tomee7/target/apache-tomee-webprofile-1.0.0-beta-2-SNAPSHOT/webapps/TomEnvEntryWeb/: Unknown module type: url=file:/Users/jacek/oss/openejb/assembly/openejb-tomcat/openejb-tomcat-bundle/tomee7/target/apache-tomee-webprofile-1.0.0-beta-2-SNAPSHOT/webapps/TomEnvEntryWeb/
      at org.apache.openejb.config.DeploymentLoader.load(DeploymentLoader.java:140)
      at org.apache.openejb.tomcat.catalina.TomcatWebAppBuilder.loadApplication(TomcatWebAppBuilder.java:890)
      ... 49 more
      Caused by: org.apache.openejb.config.UnknownModuleTypeException: Unknown module type: url=file:/Users/jacek/oss/openejb/assembly/openejb-tomcat/openejb-tomcat-bundle/tomee7/target/apache-tomee-webprofile-1.0.0-beta-2-SNAPSHOT/webapps/TomEnvEntryWeb/
      at org.apache.openejb.config.DeploymentLoader.discoverModuleType(DeploymentLoader.java:1463)
      at org.apache.openejb.config.DeploymentLoader.discoverModuleType(DeploymentLoader.java:1401)
      at org.apache.openejb.config.DeploymentLoader.load(DeploymentLoader.java:138)
      ... 50 more
      Oct 8, 2011 12:55:28 PM org.apache.catalina.startup.HostConfig deployWAR
      SEVERE: Error deploying web application archive TomEnvEntryWeb.war
      java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/TomEnvEntryWeb]]
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:816)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:787)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:607)
      at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:932)
      at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:529)
      at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1384)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.tomcat.util.modeler.BaseModelMBean.invoke(BaseModelMBean.java:301)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:836)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:761)
      at org.apache.catalina.manager.ManagerServlet.check(ManagerServlet.java:1436)
      at org.apache.catalina.manager.HTMLManagerServlet.upload(HTMLManagerServlet.java:334)
      at org.apache.catalina.manager.HTMLManagerServlet.doPost(HTMLManagerServlet.java:211)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:641)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:304)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.filters.CsrfPreventionFilter.doFilter(CsrfPreventionFilter.java:187)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:108)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:224)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:185)
      at org.apache.openejb.tomcat.catalina.OpenEJBValve.invoke(OpenEJBValve.java:44)
      at org.apache.openejb.tomcat.catalina.OpenEJBValve.invoke(OpenEJBValve.java:44)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:581)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:151)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:100)
      at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:929)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:405)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:269)
      at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:515)
      at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:300)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:680)

        Activity

        jlaskowski Jacek Laskowski added a comment -

        Committed revision 1180457

        dblevins David Blevins added a comment -

          People

          • Assignee:
            jlaskowski Jacek Laskowski
            Reporter:
            jlaskowski Jacek Laskowski
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development