Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Invalid
    • Affects Version/s: 1.1.3
    • Fix Version/s: None
    • Component/s: Calendar
    • Labels:
      None

      Description

      The method assigned by the "validator" attribute on the t:inputCalendar tag is not called if the inputCalendar's own validation fails. My understanding, which I grant might be incorrect, is that this attribute should either override or supplement the component's internal validation.

      For example, if "not a date" is entered into the calendar's input box, the calendar's validation reports a message of 'The given value "not a date" could not be converted to a date.' Further validation does not occur even if the "validator" attribute is set. This would be useful if the application needs to reset or clear other field values when an invalid date is entered. If, on the other hand, a proper date is entered, then both the calendar's validation and the specified validator method are called.

        Activity

        Leonardo Uribe added a comment -

        The behavior presented depends of myfaces core, because this code is implemented on javax.faces.component.UIInput. The problem is that the validation has two phases: first convert the submitted value, if no validation error validate all registered validators. The actual behavior is what is spected according to jsf spec.

        This issue should be close as invalid.

        Thanks for the suggestions.


          People

          • Assignee:
            Leonardo Uribe
            Reporter:
            Richard J. Barbalace
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development