Before 3.3.0, we need to get the story around collections straight. Currently we are relying on JSON collections to represent our collections, but this isn't always sound – e.g. JSON maps can only have string keys.
Thus, we need:
Note that all of these would just be JSON lists:
Next, these data structures are exactly what play into aggregateTo in sideEffects for RemoteConnection. Thus, we should use these types and, as well, get rid of none as the aggregate would be a real type like g:Int32.
Also, I think we should abandon this hybrid physical machine naming convention and programming language type convention.
If we want to be consistent either do the above or do the below, though I think the above is cleaner.
Again, using programming lexicon vs. physical machine lexicon is best and thus, just gut "int32" and "int64."