Right now we have two keys for input to a HadoopGraph.
Likewise for output. I have so many if/else checks because both of these can be set that I think we should make one and only one input.
Likewise, for output: gremlin.hadoop.graphOutputClass.
This will make things so much simpler. However, it will break current implementations (and not backwards compatible).