Tika
  1. Tika
  2. TIKA-210

html content directly under body node not parsed correctly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.3
    • Fix Version/s: 0.4
    • Component/s: parser
    • Labels:
      None

      Description

      The html parser does not correctly parse content that is directly under the body node, when passing html like this: <html><body>This is my content</body></html>, an empty string is returned when calling BodyContentHandler#toString()

        Activity

        Daan de Wit created issue -
        Jukka Zitting added a comment -

        This was caused by the XHTMLContentHandler postponing the output of the XHTML prefix to when the first start tag inside the <body> is seen.

        Fixed in revision 757747.

        Jukka Zitting made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Jukka Zitting [ jukkaz ]
        Fix Version/s 0.4 [ 12313700 ]
        Resolution Fixed [ 1 ]
        Jukka Zitting made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1d 2m 1 Jukka Zitting 24/Mar/09 11:58
        Resolved Resolved Closed Closed
        134d 9h 16m 1 Jukka Zitting 05/Aug/09 21:15

          People

          • Assignee:
            Jukka Zitting
            Reporter:
            Daan de Wit
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development