Uploaded image for project: 'Tika'
  1. Tika
  2. TIKA-1877

On updating the tika-mimetypes.xml to detect .fts file format, tika detector does not return anything

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • None
    • 1.13
    • mime
    • None

    Description

      The match value for .fts file format in tika-mimetypes.xml is "SIMPLE = T".
      Tika detected a .fts file as application/octet-stream. On verifying the header I found the value to be "SIMPLE = T"(just 16 spaces before = and T)

      I tried the following changes-
      Change 1) Updated the existing match value. But the build failed

      Change 2) Added a new match value <match value="SIMPLE = T" type="string" offset="0"/> after the existing one.
      But now, tika returns empty value. It neither identifies the file as .fts nor as application/octet-stream.

      Attachments

        1. tika-mimetypes.xml
          226 kB
          Prasad Nagaraj Subramanya
        2. 4E8D6B46E2366D7063DE3926AF0F976A0DCCD57A7E3B53B7D54768F16DD23984
          64 kB
          Prasad Nagaraj Subramanya
        3. 3DEE2CE70CAD248DC8A46C2D0BD0BD6C21AACE54AC958264773390B39C8AF079
          64 kB
          Namitha Sanjeeva Ganiga

        Issue Links

          Activity

            People

              Unassigned Unassigned
              prasadns14 Prasad Nagaraj Subramanya
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: