Uploaded image for project: 'Tika'
  1. Tika
  2. TIKA-1524

Can install Tika-Bundle, missing JUnit dependency

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.10
    • Component/s: packaging
    • Labels:
      None
    • Environment:

      Karaf 2.3.6

      Description

      When I'm trying to install a feature which has a dependency on the Tika-Bundle, it fails to install. It indicates it's missing a dependency to JUnit.

      Momentarily I solved this for myself by reverting back to Tika-Bundle version 1.6

      Error executing command: Could not start bundle mvn:org.apache.tika/tika-bundle/1.7 in feature(s): Unresolved constraint in bundle org.apache.tika.bundle [336]: Unable to resolve 336.0: missing requirement [336.0] osgi.wiring.package; (osgi.wiring.package=org.junit.internal)

        Attachments

        1. TIKA-1524.patch
          3 kB
          Konstantin Gribov
        2. TIKA-1524.patch
          0.8 kB
          Konstantin Gribov
        3. TIKA-1524.patch
          0.4 kB
          Bob Paulin
        4. TikaBundleNoJUnit.patch
          2 kB
          Bob Paulin

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              niels Niels
            • Votes:
              1 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: