Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-4724

dlang dub.json dependency for openssl is too restrictive

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.12.0
    • Fix Version/s: 0.13.0
    • Component/s: D - Library
    • Labels:
      None

      Description

      In reviewing the dub.json file it specifies this deimos openssl dependency:

          "openssl": {
            "version": "~>1.1.6"
          }
      

      This limits package dependencies to native OpenSSL 1.0 systems only. The correct dependency should be:

          "openssl": {
            "version": ">=1.1.6"
          }
      

      This allows the consumer to use either the v1.1.6 (OpenSSL 1.0 compatible) or v2.0.0 (OpenSSL 1.1 compatible) version of the OpenSSL deimos package.

      The `systemDependencies` field should be updated to reflect this as well.

        Attachments

          Activity

            People

            • Assignee:
              jking3 James E. King III
              Reporter:
              jking3 James E. King III
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: