Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-3207

Enable build with OpenSSL 1.1.0 series

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.9.2
    • Fix Version/s: 0.11.0
    • Component/s: C++ - Library
    • Labels:
    • Patch Info:
      Patch Available
    • Flags:
      Patch

      Description

      As thrift requires OpenSSL v1.1.0 there are still some problems with compiling latest official releases on Visual Studio 2013. We falled back to other OpenSSL releases that source version can be compiled without problems.

      Unfortunately Thrift can not be build against OpenSSL pre 1.1.0 due to missing TLSv1_1_method() and TLSv1_2_method().

      While OpenSSL in version 0.9.8 and 1.0.0 is supported till 2015-12-31 and Open SSL in version 1.0.1 and 1.0.2 is supported till 2016-12-31 we found reasonable to enable this releases to be used for Thrift builds.

      The proposed patch enables Thrift support of TLS 1.1 and 1.2 only when build with OpenSSL 1.1.0 or newer.

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              jensg Jens Geyer
              Reporter:
              pjanicki Paweł Janicki

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment