Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-1629

Ruby 1.9 Compatibility during Thrift configure, make, install

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8
    • Fix Version/s: 0.9.1
    • Component/s: Ruby - Library
    • Labels:
      None
    • Environment:

      Mac OSX, *nix

      Description

      I downloaded the 0.8 stable version of Thrift and began by performing the configure, make tasks. It appears that this version of Thrift is not compatible with Ruby 1.9.

      The problem encountered is that Ruby library inside Thrift includes the Mongrel web server. Mongrel does not work with Ruby 1.9. A drop in replacement for Mongrel is the Thin web server, and there are also several other choices.

      I have submitted a pull request via Github to resolve this matter.
      https://github.com/apache/thrift/pull/23

      Thanks.
      Nick Zalabak
      @techwhizbang

        Attachments

          Activity

            People

            • Assignee:
              techwhizbang Nick Zalabak
              Reporter:
              techwhizbang Nick Zalabak
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: