Uploaded image for project: 'Thrift'
  1. Thrift
  2. THRIFT-1370

Debian packaging should Build-Depend on libglib2.0-dev

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.7
    • Fix Version/s: 0.8
    • Labels:
    • Environment:

      OS=Debian

    • Patch Info:
      Patch Available

      Description

      The Debian packaging builds the c_glib interface library, but does not name libglib2.0-dev as a Build-Dependency. While this usually won't affect manual builds, this is a problem for automated build environments which will not have libglib2.0-dev installed unless explicitly requested by Build-Depends.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ch2500 Christian Hofstaedtler

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment