Uploaded image for project: 'Apache Tez'
  1. Apache Tez
  2. TEZ-2068

Tez UI: Dag view should use full window height, disable webuiservice in localmode

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.6.1
    • Component/s: None
    • Labels:
      None

      Description

      Use available vertical space.

      1. TEZ-2068.3.patch
        4 kB
        Sreenath Somarajapuram
      2. TEZ-2068.2.patch
        2 kB
        Sreenath Somarajapuram
      3. TEZ-2068.1.patch
        3 kB
        Sreenath Somarajapuram

        Activity

        hitesh Hitesh Shah added a comment -

        Closing issue as 0.5.4, 0.6.1 and 0.7.0 have been released.

        hitesh Hitesh Shah added a comment -

        Committed to master and branch 0.6. Thanks Bikas Saha, Prakash Ramachandran and Sreenath Somarajapuram

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12698144/TEZ-2068.3.patch
        against master revision b336ca0.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in .

        Test results: https://builds.apache.org/job/PreCommit-TEZ-Build/169//testReport/
        Console output: https://builds.apache.org/job/PreCommit-TEZ-Build/169//console

        This message is automatically generated.

        pramachandran Prakash Ramachandran added a comment -

        +1 for patch 3 lgtm.

        Sreenath Sreenath Somarajapuram added a comment -

        Attaching patch 3 with the missed file.

        pramachandran Prakash Ramachandran added a comment -

        Sreenath Somarajapuram the second patch is missing the dag_view.js file.

        pramachandran Prakash Ramachandran added a comment -

        UT failure is due to an unrelated issue (TEZ-2058).

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12698126/TEZ-2068.2.patch
        against master revision b336ca0.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in :
        org.apache.tez.test.TestTezJobs

        Test results: https://builds.apache.org/job/PreCommit-TEZ-Build/168//testReport/
        Console output: https://builds.apache.org/job/PreCommit-TEZ-Build/168//console

        This message is automatically generated.

        Sreenath Sreenath Somarajapuram added a comment - - edited

        Adding a patch 2 with additional changes to disable webuiservices in localmode.

        hitesh Hitesh Shah added a comment -

        Makes sense for now. At some point, if any client code starts using the webservice, we can re-think that later.

        pramachandran Prakash Ramachandran added a comment -

        Hitesh Shah/Bikas Saha regarding the failure for TestPreEmption shall I disable the webuiservice for the local mode?

        pramachandran Prakash Ramachandran added a comment -

        +1 lgtm.

        hitesh Hitesh Shah added a comment -

        Hmm, are service start failures not caught properly in local mode?

        bikassaha Bikas Saha added a comment -

        Apparently some issue in AM starting up. So it timed out before running anything.

        2015-02-10 18:46:15,143 INFO [Thread-79] client.LocalClient (LocalClient.java:startDAGAppMaster(221)) - DAGAppMaster state: INITED
        2015-02-10 18:46:15,143 INFO [Thread-79] client.LocalClient (LocalClient.java:startDAGAppMaster(225)) - DAGAppMaster is not startetd wait for 100ms...
        2015-02-10 18:46:15,143 INFO [Thread-79] client.LocalClient (LocalClient.java:startDAGAppMaster(236)) - DAGAppMaster is not created wait for 100ms...
        2015-02-10 18:46:15,177 INFO [ServiceThread:org.apache.tez.dag.app.web.WebUIService] mortbay.log (Slf4jLog.java:info(67)) - NO JSP Support for /, did not find org.apache.jasper.servlet.JspServlet
        2015-02-10 18:46:15,183 WARN [ServiceThread:org.apache.tez.dag.app.web.WebUIService] amfilter.AmIpFilter (AmIpFilter.java:init(89)) - http://asf900.gq1.ygridcore.net:8088null does not appear to be a valid URL
        java.net.MalformedURLException: For input string: "8088null"
        at java.net.URL.<init>(URL.java:619)
        at java.net.URL.<init>(URL.java:482)
        at java.net.URL.<init>(URL.java:431)
        at org.apache.hadoop.yarn.server.webproxy.amfilter.AmIpFilter.init(AmIpFilter.java:86)
        at org.mortbay.jetty.servlet.FilterHolder.doStart(FilterHolder.java:97)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.servlet.ServletHandler.initialize(ServletHandler.java:713)
        at org.mortbay.jetty.servlet.Context.startContext(Context.java:140)
        at org.mortbay.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1282)
        at org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:518)
        at org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:499)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.handler.HandlerCollection.doStart(HandlerCollection.java:152)
        at org.mortbay.jetty.handler.ContextHandlerCollection.doStart(ContextHandlerCollection.java:156)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.handler.HandlerWrapper.doStart(HandlerWrapper.java:130)
        at org.mortbay.jetty.Server.doStart(Server.java:224)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.apache.hadoop.http.HttpServer2.start(HttpServer2.java:828)
        at org.apache.hadoop.yarn.webapp.WebApps$Builder.start(WebApps.java:273)
        at org.apache.tez.dag.app.web.WebUIService.serviceStart(WebUIService.java:82)
        at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
        at org.apache.tez.dag.app.DAGAppMaster$ServiceWithDependency.start(DAGAppMaster.java:1448)
        at org.apache.tez.dag.app.DAGAppMaster$ServiceThread.run(DAGAppMaster.java:1466)
        Caused by: java.lang.NumberFormatException: For input string: "8088null"
        at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
        at java.lang.Integer.parseInt(Integer.java:492)
        at java.lang.Integer.parseInt(Integer.java:527)
        at java.net.URLStreamHandler.parseURL(URLStreamHandler.java:217)
        at java.net.URL.<init>(URL.java:614)
        ... 23 more
        2015-02-10 18:46:15,189 WARN [ServiceThread:org.apache.tez.dag.app.web.WebUIService] amfilter.AmIpFilter (AmIpFilter.java:init(89)) - http://asf900.gq1.ygridcore.net:8088null does not appear to be a valid URL
        java.net.MalformedURLException: For input string: "8088null"
        at java.net.URL.<init>(URL.java:619)
        at java.net.URL.<init>(URL.java:482)
        at java.net.URL.<init>(URL.java:431)
        at org.apache.hadoop.yarn.server.webproxy.amfilter.AmIpFilter.init(AmIpFilter.java:86)
        at org.mortbay.jetty.servlet.FilterHolder.doStart(FilterHolder.java:97)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.servlet.ServletHandler.initialize(ServletHandler.java:713)
        at org.mortbay.jetty.servlet.Context.startContext(Context.java:140)
        at org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:518)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.handler.HandlerCollection.doStart(HandlerCollection.java:152)
        at org.mortbay.jetty.handler.ContextHandlerCollection.doStart(ContextHandlerCollection.java:156)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.mortbay.jetty.handler.HandlerWrapper.doStart(HandlerWrapper.java:130)
        at org.mortbay.jetty.Server.doStart(Server.java:224)
        at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
        at org.apache.hadoop.http.HttpServer2.start(HttpServer2.java:828)
        at org.apache.hadoop.yarn.webapp.WebApps$Builder.start(WebApps.java:273)
        at org.apache.tez.dag.app.web.WebUIService.serviceStart(WebUIService.java:82)
        at org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
        at org.apache.tez.dag.app.DAGAppMaster$ServiceWithDependency.start(DAGAppMaster.java:1448)
        at org.apache.tez.dag.app.DAGAppMaster$ServiceThread.run(DAGAppMaster.java:1466)
        Caused by: java.lang.NumberFormatException: For input string: "8088null"
        at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
        at java.lang.Integer.parseInt(Integer.java:492)
        at java.lang.Integer.parseInt(Integer.java:527)
        at java.net.URLStreamHandler.parseURL(URLStreamHandler.java:217)
        at java.net.URL.<init>(URL.java:614)
        ... 21 more
        2015-02-10 18:46:15,190 INFO [ServiceThread:org.apache.tez.dag.app.web.WebUIService] mortbay.log (Slf4jLog.java:info(67)) - Started HttpServer2$SelectChannelConnectorWithSafeStartup@0.0.0.0:37786
        2015-02-10 18:46:15,190 INFO [ServiceThread:org.apache.tez.dag.app.web.WebUIService] webapp.WebApps (WebApps.java:start(274)) - Web app / started at 37786
        2015-02-10 18:46:15,206 INFO [ServiceThread:org.apache.tez.dag.app.web.WebUIService] webapp.WebApps (WebApps.java:start(288)) - Registered webapp guice modules
        2015-02-10 18:46:15,243 INFO [Thread-79] client.LocalClient (LocalClient.java:startDAGAppMaster(221)) - DAGAppMaster state: INITED
        2015-02-10 18:46:15,243 INFO [Thread-79] client.LocalClient (LocalClient.java:startDAGAppMaster(225)) - DAGAppMaster is not startetd wait for 100ms...
        2015-02-10 18:46:15,243 INFO [Thread-79] client.LocalClient (LocalClient.java:startDAGAppMaster(236)) - DAGAppMaster is not created wait for 100ms...
        2015-02-10 18:46:15,343 INFO [Thread-79] client.LocalClient (LocalClient.java:startDAGAppMaster(221)) - DAGAppMaster state: INITED
        2015-02-10 18:46:15,344 INFO [Thread-79] client.LocalClient (LocalClient.java:startDAGAppMaster(225)) - DAGAppMaster is not startetd wait for 100ms...

        hitesh Hitesh Shah added a comment -

        Bikas Saha Mind taking a look and filing a jira for the flaky test in TestPreemption?

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12697832/TEZ-2068.1.patch
        against master revision 12c31ab.

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in :
        org.apache.tez.dag.app.TestPreemption

        Test results: https://builds.apache.org/job/PreCommit-TEZ-Build/158//testReport/
        Console output: https://builds.apache.org/job/PreCommit-TEZ-Build/158//console

        This message is automatically generated.

        Sreenath Sreenath Somarajapuram added a comment -

        Prakash Ramachandran Please review the patch.


          People

          • Assignee:
            Sreenath Sreenath Somarajapuram
            Reporter:
            Sreenath Sreenath Somarajapuram
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development