Tapestry
  1. Tapestry
  2. TAPESTRY-544

Unmatched <p> and DatePicker problem in MSIE 6

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.0
    • Fix Version/s: 4.1.1
    • Component/s: Framework
    • Labels:
      None
    • Environment:
      MSIE 6.0, Windows XP SP 2

      Description

      This concerns all beta versions of 4.0, even including tonight's CVS HEAD, which is supposed to be Beta-4.

      Whenever I use an unmatched <p>, or even a <p/>, without an explicit </p> in a page with a DatePicker, I get a really strange error from MSIE, in that MSIE pops up the error dialog "Operation aborted." It does NOT happen when I match the <p> tag with a </p> or use other components, such as TextField.

      The simplest page yielding this problem:

      <html>
      <body jwcid="@Body">
      <p/>
      <form jwcid="@Form">
      <input jwcid="@DatePicker" value="ognl:theDate" type="text" size="12" />
      </form>
      </body>
      </html>

      Just remove the <p/> and it works. Very absurd. Have tried with a handful of MSIE 6 machines.

        Activity

        Howard M. Lewis Ship added a comment -

        Yep, this seems to happen. Only in IE. Once it happens, IE fails to send further requests to the server (I see no requests in the NCSA log). Not sure how to proceed!

        Mario Siegenthaler added a comment -

        As far as I tracked down this issue the problem is that the IE really dislikes the <script> of the DatePicker if it's not a top level element (directly under the body). I got the same 'operation aborted' message.
        The only solution that worked was to open and close all elements properly. I even had a problem with a <div/> tag I had to change to <div></div> because the IE was too stupid to recognize the first one as closed. Maybe it's the same problem here. I'd try a <p></p>. In such a scenario I found the IE-Webdeveloper Toolbars DOM-Inspector to be a great help.

        Jesse Kuhnert added a comment -

        I can't currently reproduce this. It's possible I fixed it during some other commit but either way it doesn't happen now so ..


          People

          • Assignee:
            Unassigned
            Reporter:
            David Bergman
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development