Tapestry
  1. Tapestry
  2. TAPESTRY-399

If a RedirectException is thrown after IEngine.setLocale(...) has been called, the cookie org.apache.tapestry.locale is not being set

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.1.2
    • Fix Version/s: 4.1.3
    • Component/s: Framework
    • Labels:
      None

      Description

      At the moment it seems not to be possible to change the engine locale and redirect to the current page so the locale settings take effect immediatly. As you can see I tried doing the redirect manually (via .forward()), but that didn't change a thing.

      WORK AROUND -------------------------
      Work-around (this seems to work in Beta 2):
      @InjectObject("infrastructure:cookieSource")
      public abstract CookieSource getCookieSource();

      then in the listener do:
      // note that Locale.toString() returns the programmatic code of the locale (for example "de_DE" or "en_US")
      getCookieSource().writeCookieValue("org.apache.tapestry.locale", Locale.GERMANY.toString());
      throw new RedirectException([myurl]);

      TEST CODE -------------------------

      template:
      <a jwcid="@ActionLink" stateful="false" listener="ognl:listeners.changeToGerman">de</a>

      listener:

      public void changeToGerman(IRequestCycle cycle)

      { cycle.getEngine().setLocale(Locale.GERMANY); // this also does not send the cookie // cycle.getInfrastructure().getRequest().forward(getEngineService().getLink(cycle, cycle.getPage().getPageName()).getAbsoluteURL()); throw new RedirectException(getEngineService().getLink(cycle, cycle.getPage().getPageName()).getURL()); }

      @InjectObject("engine-service:page")
      public abstract IEngineService getEngineService();

      Header dump:

      actual response:
      HTTP/1.x 302 Moved Temporarily
      Server: Apache-Coyote/1.1
      Location: http://localhost:81/cip/Home.cip
      Content-Length: 0
      Date: Thu, 14 Jul 2005 14:04:57 GMT

      expected response:
      HTTP/1.x 302 Moved Temporarily
      Server: Apache-Coyote/1.1
      Location: http://localhost:81/cip/Home.cip
      Content-Length: 0
      Date: Thu, 14 Jul 2005 14:04:57 GMT
      Set-Cookie: org.apache.tapestry.locale=de_DE; Path=/cip

        Activity

        Jesse Kuhnert added a comment -

        Ok, should really be fixed now.

        Jonas Maurus added a comment -

        I'm sorry, after 1.5 years I didn't monitor this bug closely anymore, so I only just found out that you closed it as invalid and so my response comes a bit late.

        It seems my test code didn't make the issue obvious enough. The problem is not that cycle.engine.setLocale() doesn't work if you send the user to another page, like in the workbench, the problem is that it doesn't work if you send the user to the same page from an ActionLink using a RedirectException.

        For some reason the cookie-header is not set on the response when the exception is thrown, so you can't change the locale and redirect the user.

        Setting the cookie manually is the work-around. The test code sets the locale on the engine to demonstrate it doesn't work.

        You might want to reinvestigate. The test code posted in the description at least doesn't work in version 4.0.2.

        Jesse Kuhnert added a comment -

        You can change the locale quite easily by setting it on the engine object instead of trying to muck about with the cookies manually.

        For an example see:

        http://svn.apache.org/viewvc/tapestry/tapestry4/trunk/tapestry-examples/Workbench/src/context/WEB-INF/localization/Localization.page?view=markup

        Notice the inputLocale component setting the value binding to be "page.engine.locale" . This is what sets it. A running example of it can be found here:

        http://opencomponentry.com:8080/workbench/Home,$Border.pageLink.sdirect?sp=Slocalization%2FLocalization


          People

          • Assignee:
            Jesse Kuhnert
            Reporter:
            Jonas Maurus
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development