Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 4.1.5
    • Fix Version/s: 4.1.6
    • Component/s: Framework
    • Labels:
      None
    • Environment:
      fedora core 6, firefox 2.0.0.12, jetty 6.1.5

      Description

      An image button cannot refresh the form because the submitmode is resetted before the form gets actually submitted.

      As a solution it is suggested to change form.refresh to the following form. So only after an async commit the state of the form is resetted:

      tapestry.form.refresh = function(form, submitName, parms) {
      form = dojo.byId(form);
      if (!form)

      { dojo.raise("Form not found with id " + form); return; }

      var formName = form.getAttribute("id");
      var validateState = tapestry.form.forms[formName].validateForm;
      tapestry.form.setFormValidating(formName, false);
      var previous = form.submitmode.value;
      form.submitmode.value = "refresh";
      if (parms && !dj_undef("async", parms) && parms.async)

      { this.submitAsync(form, null, submitName, parms); form.submitmode.value = previous; tapestry.form.setFormValidating(formName, validateState); }

      else

      { this.submit(form, submitName, parms); }


      };

        Activity

        Robert Binna created issue -
        Andreas Andreou made changes -
        Field Original Value New Value
        Assignee Andreas Andreou [ andyhot ]
        Andreas Andreou made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Andreas Andreou added a comment -

        Was caused by the fix for TAPESTRY-1775 at least there are some more
        selenium tests now... A new 4.1.6-SNAPSHOT is already deployed for you to try.

        Andreas Andreou made changes -
        Fix Version/s 4.1.6 [ 12312957 ]
        Status In Progress [ 3 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Mark Thomas made changes -
        Workflow jira [ 12424945 ] Default workflow, editable Closed status [ 12569376 ]
        Mark Thomas made changes -
        Workflow Default workflow, editable Closed status [ 12569376 ] jira [ 12590634 ]

          People

          • Assignee:
            Andreas Andreou
            Reporter:
            Robert Binna
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development