Tapestry
  1. Tapestry
  2. TAPESTRY-1914

Nightly build broken inside quickstart module

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 5.0.7
    • Fix Version/s: 5.0.7
    • Component/s: quickstart
    • Labels:
      None

      Description

      Breaking as so:

      15-Nov-2007 08:00:46 [INFO] ----------------------------------------------------------------------------
      15-Nov-2007 08:00:46 [INFO] Building Tapestry 5 Quickstart Archetype
      15-Nov-2007 08:00:46 [INFO] task-segment: [clean, deploy, site, site:deploy]
      15-Nov-2007 08:00:46 [INFO] ----------------------------------------------------------------------------
      15-Nov-2007 08:00:46 [INFO] [clean:clean]
      15-Nov-2007 08:00:46 [INFO] Deleting directory /home/​bamboo/​bambooData/​xml-data/​build-dir/​T5-NGT/​quickstart/​target
      15-Nov-2007 08:00:46 [INFO] Deleting directory /home/​bamboo/​bambooData/​xml-data/​build-dir/​T5-NGT/​quickstart/​target/​classes
      15-Nov-2007 08:00:46 [INFO] Deleting directory /home/​bamboo/​bambooData/​xml-data/​build-dir/​T5-NGT/​quickstart/​target/​test-classes
      15-Nov-2007 08:00:46 [INFO] Deleting directory /home/​bamboo/​bambooData/​xml-data/​build-dir/​T5-NGT/​quickstart/​target/​site
      15-Nov-2007 08:00:46 [INFO] [plugin:descriptor]
      15-Nov-2007 08:00:46 [INFO] Using 2 extractors.
      15-Nov-2007 08:00:46 [INFO] Applying extractor for language: java
      15-Nov-2007 08:00:46 [INFO] Extractor for language: java found 0 mojo descriptors.
      15-Nov-2007 08:00:46 [INFO] Applying extractor for language: bsh
      15-Nov-2007 08:00:46 [INFO] Extractor for language: bsh found 0 mojo descriptors.
      15-Nov-2007 08:00:46 [INFO] ------------------------------------------------------------------------
      15-Nov-2007 08:00:46 [ERROR] BUILD ERROR
      15-Nov-2007 08:00:46 [INFO] ------------------------------------------------------------------------
      15-Nov-2007 08:00:46 [INFO] Error extracting plugin descriptor: 'No mojo descriptors found in plugin.'
      15-Nov-2007 08:00:46
      15-Nov-2007 08:00:46 [INFO] ------------------------------------------------------------------------
      15-Nov-2007 08:00:46 [INFO] For more information, run Maven with the -e switch
      15-Nov-2007 08:00:46 [INFO] ------------------------------------------------------------------------
      15-Nov-2007 08:00:46 [INFO] Total time: 9 minutes 30 seconds
      15-Nov-2007 08:00:46 [INFO] Finished at: Thu Nov 15 08:00:46 PST 2007
      15-Nov-2007 08:00:46 [INFO] Final Memory: 34M/​77M
      15-Nov-2007 08:00:46 [INFO] ------------------------------------------------------------------------

      There haven't been any changes lately.

      Removing quickstart from the build temporarily.

        Activity

        Hide
        Christian E Gruber added a comment -

        You need to add this to the pluginmanagement section of the parent pom.xml

        <plugin>
        <artifactId>maven-plugin-plugin</artifactId>
        <version>2.3</version>
        </plugin>

        At this point, for some reason, it's pulling in a 2.4-snapshot. 2.4-snapshot apparently doesn't like the whole "no mojo classes" aspect of an archetype. Since there's a whole new archetype system under development, it's not worth converting things or bitching at the maven team yet. Just use the 2.3 version of the plugin and lock it in.

        Show
        Christian E Gruber added a comment - You need to add this to the pluginmanagement section of the parent pom.xml <plugin> <artifactId>maven-plugin-plugin</artifactId> <version>2.3</version> </plugin> At this point, for some reason, it's pulling in a 2.4-snapshot. 2.4-snapshot apparently doesn't like the whole "no mojo classes" aspect of an archetype. Since there's a whole new archetype system under development, it's not worth converting things or bitching at the maven team yet. Just use the 2.3 version of the plugin and lock it in.
        Hide
        Howard M. Lewis Ship added a comment -

        Thanks for the fix, worked like a charm!

        Show
        Howard M. Lewis Ship added a comment - Thanks for the fix, worked like a charm!
        Hide
        James Carman added a comment -

        We ran into this today because it broke our build. Apparently, they've released the 2.4 version officially. I filed a bug for it:

        http://jira.codehaus.org/browse/MPLUGIN-102

        Show
        James Carman added a comment - We ran into this today because it broke our build. Apparently, they've released the 2.4 version officially. I filed a bug for it: http://jira.codehaus.org/browse/MPLUGIN-102
        Show
        Brian Fox added a comment - FYI: http://www.nabble.com/-Pre-Vote--release-maven-2.0.9-tt16124759s177.html#a16124759

          People

          • Assignee:
            Howard M. Lewis Ship
            Reporter:
            Howard M. Lewis Ship
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development